Photogtaphy Forums

Photography Forums > Camera Manufacturers > Olympus > Olympus E-410/510, horrifying magenta highlight problem

Reply
Thread Tools Display Modes

Olympus E-410/510, horrifying magenta highlight problem

 
 
RichA
Guest
Posts: n/a

 
      08-11-2007, 12:02 AM
Shades of Leica with the purple blacks? No, Leica owned up to the
problem. Olympus is keeping dead silent and letting the guinea pigs,
er, customers sort it out.

I'm not used to this. Olympus releasing cameras with flaws. Most
Olympus (compared to many other brands) work without a hitch. Not
this time. Much speculation as to the cause.

http://forums.dpreview.com/forums/re...4311898&page=3

 
Reply With Quote
 
 
 
 
John Sheehy
Guest
Posts: n/a

 
      08-11-2007, 02:00 AM
RichA <(E-Mail Removed)> wrote in news:1186790556.554355.154940
@e9g2000prf.googlegroups.com:

> Shades of Leica with the purple blacks? No, Leica owned up to the
> problem. Olympus is keeping dead silent and letting the guinea pigs,
> er, customers sort it out.
>
> I'm not used to this. Olympus releasing cameras with flaws. Most
> Olympus (compared to many other brands) work without a hitch. Not
> this time. Much speculation as to the cause.


This is a simple case of RAW converters not recognizing the real clipping
points in the RAW data.

--

<>>< ><<> ><<> <>>< ><<> <>>< <>>< ><<>
John P Sheehy <(E-Mail Removed)>
><<> <>>< <>>< ><<> <>>< ><<> ><<> <>><

 
Reply With Quote
 
 
 
 
Pete D
Guest
Posts: n/a

 
      08-11-2007, 06:16 AM
OMG, OMG, OMG, OMG, OMG, OMG.
OMG, OMG, OMG, OMG, OMG, OMG.
OMG, OMG, OMG, OMG, OMG, OMG.
OMG, OMG, OMG, OMG, OMG, OMG.
OMG, OMG, OMG, OMG, OMG, OMG.
OMG, OMG, OMG, OMG, OMG, OMG.
OMG, OMG, OMG, OMG, OMG, OMG.
OMG, OMG, OMG, OMG, OMG, OMG.
"RichA" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed) ups.com...
> Shades of Leica with the purple blacks? No, Leica owned up to the
> problem. Olympus is keeping dead silent and letting the guinea pigs,
> er, customers sort it out.
>
> I'm not used to this. Olympus releasing cameras with flaws. Most
> Olympus (compared to many other brands) work without a hitch. Not
> this time. Much speculation as to the cause.
>
> http://forums.dpreview.com/forums/re...4311898&page=3
>



 
Reply With Quote
 
Alfred Molon
Guest
Posts: n/a

 
      08-11-2007, 07:58 AM
In article <(E-Mail Removed). com>, RichA
says...
> Shades of Leica with the purple blacks? No, Leica owned up to the
> problem. Olympus is keeping dead silent and letting the guinea pigs,
> er, customers sort it out.
>
> I'm not used to this. Olympus releasing cameras with flaws. Most
> Olympus (compared to many other brands) work without a hitch. Not
> this time. Much speculation as to the cause.
>
> http://forums.dpreview.com/forums/re...4311898&page=3


As written there, the difference between 3900 and 4095 is minimal
(1/14th of a stop). I doubt this has an impact on image quality. Do you
have any sample images which prove otherwise?

By the way, all RAW images of the Sony R1 I have here have a more or
less strong red colour cast, which I have to correct during RAW
conversion.
--

Alfred Molon
------------------------------
Olympus 50X0, 7070, 8080, E3X0, E4X0 and E5X0 forum at
http://tech.groups.yahoo.com/group/MyOlympus/
http://myolympus.org/ photo sharing site
 
Reply With Quote
 
DMac
Guest
Posts: n/a

 
      08-11-2007, 09:59 AM
On Aug 11, 10:02 am, RichA <(E-Mail Removed)> wrote:
> Shades of Leica with the purple blacks? No, Leica owned up to the
> problem. Olympus is keeping dead silent and letting the guinea pigs,
> er, customers sort it out.
>
> I'm not used to this. Olympus releasing cameras with flaws. Most
> Olympus (compared to many other brands) work without a hitch. Not
> this time. Much speculation as to the cause.
>
> http://forums.dpreview.com/forums/re...22&thread=2431...


For starters... It might have an Olympus badge but it's a Panasonic
camera. Made by Panasonic and shipped to Olympus for distribution. I
have no doubt whatsoever there is a firmware upgrade coming real soon.
It's not a flaw either, just a miscalculation in the programming of
the raw converter. Fixed in an instant with any halfway decent image
editing program.

You tried this alarmist stunt last week with a Oly loyality bash up.
How about you find something worthwhile to try and light a fire under
instead of this lame excuse for a "fault"?

Doug

 
Reply With Quote
 
John Bean
Guest
Posts: n/a

 
      08-11-2007, 12:43 PM
On Sat, 11 Aug 2007 02:59:23 -0700, DMac
<(E-Mail Removed)> wrote:

>On Aug 11, 10:02 am, RichA <(E-Mail Removed)> wrote:
>> Shades of Leica with the purple blacks? No, Leica owned up to the
>> problem. Olympus is keeping dead silent and letting the guinea pigs,
>> er, customers sort it out.
>>
>> I'm not used to this. Olympus releasing cameras with flaws. Most
>> Olympus (compared to many other brands) work without a hitch. Not
>> this time. Much speculation as to the cause.
>>
>> http://forums.dpreview.com/forums/re...22&thread=2431...

>
>For starters... It might have an Olympus badge but it's a Panasonic
>camera. Made by Panasonic and shipped to Olympus for distribution.


I find that unlikely, but of course I don't know. Panasonic
had to buy the chassis and other components from Olympus to
build the only SLR that carries their name. Why would they
need to do that if they could make whole SLRs for Olympus?

Source references for this assertion would be good.

>You tried this alarmist stunt last week with a Oly loyality bash up.
>How about you find something worthwhile to try and light a fire under
>instead of this lame excuse for a "fault"?


He does the best he can within his abilities.

--
John Bean
 
Reply With Quote
 
Nospam
Guest
Posts: n/a

 
      08-11-2007, 06:29 PM
In message <(E-Mail Removed)>, John Bean
<(E-Mail Removed)> writes
>On Sat, 11 Aug 2007 02:59:23 -0700, DMac
><(E-Mail Removed)> wrote:
>
>>On Aug 11, 10:02 am, RichA <(E-Mail Removed)> wrote:
>>> Shades of Leica with the purple blacks? No, Leica owned up to the
>>> problem. Olympus is keeping dead silent and letting the guinea pigs,
>>> er, customers sort it out.
>>>
>>> I'm not used to this. Olympus releasing cameras with flaws. Most
>>> Olympus (compared to many other brands) work without a hitch. Not
>>> this time. Much speculation as to the cause.
>>>
>>> http://forums.dpreview.com/forums/re...22&thread=2431...

>>
>>For starters... It might have an Olympus badge but it's a Panasonic
>>camera. Made by Panasonic and shipped to Olympus for distribution.

>
>I find that unlikely, but of course I don't know. Panasonic
>had to buy the chassis and other components from Olympus to
>build the only SLR that carries their name. Why would they
>need to do that if they could make whole SLRs for Olympus?
>
>Source references for this assertion would be good.
>
>>You tried this alarmist stunt last week with a Oly loyality bash up.
>>How about you find something worthwhile to try and light a fire under
>>instead of this lame excuse for a "fault"?

>
>He does the best he can within his abilities.
>




To cut a long storey short...


are we saying there is NO real inherent problem with either of these
Olympus cameras?

They are both on my short list but after the OP's comment I was about to
remove them from the list.

BTW
Do camera manufactures issue firmware updates for their cameras?

I assume if they do u load them into the camera through the USB cable??


--
Nospam
 
Reply With Quote
 
John Bean
Guest
Posts: n/a

 
      08-11-2007, 07:14 PM
>are we saying there is NO real inherent problem with either of these
>Olympus cameras?


I don't know who "we" is, but I'm saying that. This is the
summary of the "horrifying magenta highlight problem":

1. There is no problem whatsoever shooting in JPEG.

2. There is no problem whatsoever shooting in raw and
converting with Olympus software.

3. There is no problem whatsoever shooting in raw and
converting with *any* converter unless highlights are
completely blown and you try to recover the lost highlight
data.

So, the "horrifying magenta highlight problem" isn't
actually a camera problem of any sort, rather a failure of
non-Olympus raw converters to use the correct green-channel
clip point. Now that it's been identified I expect it'll be
fixed in the next round of releases.

>They are both on my short list but after the OP's comment I was about to
>remove them from the list.


On the say-so of Rich? You have to be kidding. If whining,
whinging, and spreading doom and gloom was an Olympic sport
he'd take all the golds. He's an idiot, just ignore him.

>BTW
>Do camera manufactures issue firmware updates for their cameras?


Usually, yes.

>I assume if they do u load them into the camera through the USB cable??


Varies by manufacturer. What you assume is correct for
Olympus.

--
John Bean
 
Reply With Quote
 
Alfred Molon
Guest
Posts: n/a

 
      08-11-2007, 08:24 PM
In article <(E-Mail Removed)>, John Bean
says...

> >I assume if they do u load them into the camera through the USB cable??

>
> Varies by manufacturer. What you assume is correct for
> Olympus.


It's a relatively simple procedure, which you can do yourself.
--

Alfred Molon
------------------------------
Olympus 50X0, 7070, 8080, E3X0, E4X0 and E5X0 forum at
http://tech.groups.yahoo.com/group/MyOlympus/
http://myolympus.org/ photo sharing site
 
Reply With Quote
 
Nospam
Guest
Posts: n/a

 
      08-11-2007, 08:31 PM

>On the say-so of Rich? You have to be kidding. If whining,
>whinging, and spreading doom and gloom was an Olympic sport
>he'd take all the golds. He's an idiot, just ignore him.


OK.

The 510 is looking good to me.

Thanks again
--
Nospam
 
Reply With Quote
 
 
 
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Olympus magenta cast HORROR continues.... RichA Olympus 5 09-20-2007 11:18 AM
Chinese quality: A horrifying example RichA Digital SLR 45 03-02-2007 04:19 PM
Problem with Shadow/Highlight on CS Mac pierre d'alancaisez Photoshop Tutorials 2 03-07-2005 09:53 AM
Problem with Shadow/Highlight on CS Mac pierre d'alancaisez Photoshop 2 03-07-2005 09:53 AM
PS7 fault - whites display as magenta - grafx card problem? Gadgets Photoshop Tutorials 2 11-07-2004 12:02 PM