540EZ stopped working

Discussion in 'Photography' started by ed, Sep 6, 2004.

  1. ed

    ed Guest

    I pulled out my trusty 540EZ today and it was completely dead. Put in
    new batteries and still nothing. Any ideas before I send it off to
    Canon? I'm curious what they would charge to fix it.
     
    ed, Sep 6, 2004
    #1
    1. Advertisements

  2. ed

    Steve Guest

    Make sure of the battery positions. My daughter recently bought a new
    calculator and put one of the batteries in the wrong way around and it
    wouldn't turn on. Thats the only thing I can think of unless the new
    batteries you used were DOA.


    Steve
     
    Steve, Sep 7, 2004
    #2
    1. Advertisements

  3. ed

    ed Guest

    Yeah I thought of that. All batteries test good. Dang! Iwas hoping
    someone knew of a fuse or other such mechanism that I was overlooking.
    My fill flashes were dead on for sunsets on the beach with a 1.5 stop
    comp.
     
    ed, Sep 7, 2004
    #3
  4. ed

    BillB Guest

    Just a wild guess - is there any chance the camera also uses a
    small button cell battery? I've had a few radios that appeared to
    be dead with fresh batteries only because their little backup
    batteries used to retain memory and operate their clocks were dead.
    Two of my Canon cameras use these button cells, but they've never
    had to be replaced and I assume that they wouldn't disable the
    camera if dead and the large main batteries had a charge, but I've
    never checked this out.
     
    BillB, Sep 7, 2004
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.