Anyone...is there some connection floppy and cd ports?

Discussion in 'Amateur Video Production' started by Noel8, Jul 21, 2011.

  1. Noel8

    Noel8 Guest

    In my desktop i have both the old floppy disk port and a cd-rw. For
    quite awhile I was always having problems using my cd drive, by
    pushing the button...most of the time, it would not open, so i had to
    use a made up paper clip, insert it in the small hole and it would
    open that way. Closing was no problem, windows explorer eject always
    opened. Now, i had to use my floppy port cause i needed to get
    forgotten pics that i had on some of them. It seems that after
    inserting the floppies and removing them, made my Cd drive work with
    its button as it should have always done. I do not need that paper
    clip it seems. The next day, i tried opening the cd drive and sure
    enough, it went back to the paper clip routine. I went to a couple of
    floppies, inserted them and then tried the cd drive again and again
    it worked like it should...so i am asking, is there such a connection
    between the both of them? I am not talking about wires...but why would
    the CD drive work as it should after using the floppy? BTW, the floppy
    works great otherwise...burning and reading as it should
     
    Noel8, Jul 21, 2011
    #1
    1. Advertisements

  2. Well, you didn't say how they're connected (I mean connected to the
    computer, not to each other!). One doesn't put a floppy into one's
    floppy port, one puts a floppy one's floppy drive...

    If the floppy is connected (internally) to a floppy port and the CD
    player is connected (internally) to an IDE or a SATA port, there is *no*
    connection. Well, maybe the ground wire :)

    Furthermore, I believe the button on the CD drive has no connection to
    the computer. OK, I just experimented: I plugged two different DVD
    drives into power without connecting them to a computer, and both
    buttons worked. Also, you said that the software eject button works...

    If both are connected to USB ports, then there might be a problem with
    your USB drivers, but this is grasping at a straw. As an experiment, you
    could try plugging one or the other into a USB port you haven't used to
    see if the behavior changes.

    I would try the same sequence a number of times on different days to see
    if you just experienced a coincidence. Or look for something you're
    doing unconsciously when you use the floppy drive.

    If nothing turns up to explain the behavior, you have found what I think
    is a mystery :)
     
    Gene E. Bloch, Jul 21, 2011
    #2
    1. Advertisements

  3. Noel8

    Noel8 Guest

    LOL, both of them are not connected to each other or a usb port the
    desktop is 7-8 years old and connected the 'old fashion way' via IDE
    only cables going into the motherboard's IDE slots. Well, i have tried
    them separate days and like I said, it works fine IF i just open the
    floppy once and insert a floppy. Go figure.
     
    Noel8, Jul 22, 2011
    #3
  4. I never heard of an IDE floppy, but I don't know everything, so if
    that's what you have then there is a possible interaction I didn't
    anticipate.

    Also: if your computer is that old the CD switch might just be failing.

    As I said, try the experiment on several occasions separated in time to
    see if it's really repeatable. And maybe the effect you've seen is just
    because you pressed the CD button a few times after a time delay that
    happened just because you were using the floppy drive for a while.
     
    Gene E. Bloch, Jul 22, 2011
    #4
  5. Noel8

    J. Clarke Guest

    Geez, open the thing up, pull them both out, blow out the dust, and see
    if there's anything sticking up from one or the other that's jamming the
    other one.
     
    J. Clarke, Jul 22, 2011
    #5
  6. Noel8

    Paul Guest

    You know the hardware path to them is separate.

    The floppy controller is on the SuperI/O chip.

    The CDROM, is on either a Southbridge IDE cable or a Southbridge SATA cable.
    Or, in some cases, a separate chip is used to add more disk I/O and it
    is supporting the optical drive.

    In any case, no hardware is shared. The floppy runs of +5V,
    and the hard drive uses +5V/+12V, and they can be powered by the
    same shared cable. But if there was a power problem, they'd both
    probably feel the effects.

    In the operating system, each device type would have its own GUID,
    and the drivers for the devices also have some notion of capability.
    For example, on an Apple Macintosh, it was popular to have ejection
    capability on the floppy. While on an IBM PC compatible, the floppy
    doesn't have eject. You push the button at your leisure, to get
    the floppy, on a PC.

    The CDROM has eject, and is marked as removable media. If it wasn't
    marked as removable media, the OS probably wouldn't even contemplate
    ejection. Since it is, and the driver supports it, it is present.

    The "button" and the eject process are complicated. At the BIOS
    level, by observation, the CDROM drive listens to the button.
    Ejection is immediate.

    When an operating system is running, the OS seems to be in the
    middle of the sequence. The button is pressed - the OS is notified
    of the event - and the OS decides what to do. In the case of
    Linux, if the CD is "mounted", the front button on the optical drive
    won't work. Linux prevents a "busy" file system from being dis-mounted.
    In some cases, in a Linux/Unix environment, the user is expected to
    use something like "lsof" to find the file keeping the drive "busy".
    So the button can be locked out.

    Windows is a bit more casual about the CDROM. It doesn't mind the
    media being ejected.

    You can also find situations, where applications can open and shut
    the drawer on their own. For example, in Nero, when you burn and
    verify, at the end of the burn, the drawer opens on its own, then
    Nero closes the drawer again, and starts the verification read. So
    you can see, the logic surrounding the "button" is complicated.

    1) In BIOS, it works like a hardware button.
    2) When an OS is booted, the OS is in the middle as a mediator.
    It listens for the button. It refuses to act, if it feels like.
    Or, in the case of Nero, it can both open and shut the drawer,
    independent of the button.

    I don't have an explanation for your symptoms. Each device should
    have its own unique GUID, and any filter drivers or things that
    can meddle in the operation of the two devices, should be
    separate software stacks. So from a software perspective,
    I can't explain your symptoms.

    "Popular Device Class GUIDs" (relates to, why deleting the wrong
    UpperFilter, leads to havoc :) )
    http://pcsupport.about.com/od/driverssupport/a/device-class-guid.htm

    If your issue was related to power (unlikely), and perhaps a bad cable,
    you'd expect, during your "sequence of events", that if the CDROM
    was active and you constantly monitored the disc in there, you'd
    be able to detect if the CDROM lost power at some point.

    Paul
     
    Paul, Jul 22, 2011
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.