Are Some Card Readers Recognized by XP Better Than Others?

Discussion in 'Digital Cameras' started by jim evans, May 16, 2007.

  1. jim evans

    jim evans Guest

    I've now had two multi-card readers. I have trouble getting XP to
    recognize cards placed in the readers.

    I have three kinds of card and the experience is different for each.

    The SD cards are almost always recognized quickly.

    The SmartMedia cards are a big problem. 2/3s (or more) of the time,
    when I insert a card the LED takes a long time to come on and XP never
    sees the card. I have to try several things repeatedly to get the
    card seen. Sometimes just removing and reinserting the card over and
    over will work. Other times I disconnect the USB connection to the
    reader and reconnect it a few times. Sometimes I have to reboot.

    The CompactFlash is somewhere between these two. When I insert the
    card the LED usually comes on immediately, but I may have to wait up
    to 20 seconds for XP to see the card. Occasionally these cards
    behave like the SmartMedia cards, but (thankfully) that's fairly rare.

    I don't know whether this is an XP problem or a card reader problem.
    Are all card readers like this? The two I've had have both behaved
    this way.

    -- jim
     
    jim evans, May 16, 2007
    #1
    1. Advertisements

  2. I've never had any card reader behave like that, on XP or elsewhere.
    Currently I'm using a Sandisk reader on XP Pro, with CF, XD, and SD
    cards, and it responds quite promptly when I insert a card. It doesn't
    always pop open a window the way it's supposed to, but if I go to My
    Computer the device is there and I can open it and see the data on the card.
     
    David Dyer-Bennet, May 16, 2007
    #2
    1. Advertisements

  3. jim evans

    jim evans Guest

    The largest of these cards is a 2GB SD. The CompactFlash cards are
    ..5GB and the SmartMedia are 64MB.

    -- jim
     
    jim evans, May 16, 2007
    #3
  4. jim evans

    jim evans Guest

    Just to clarify. My reader reads all the cards great **AFTER** XP
    recognizes the card is in the reader.

    -- jim
     
    jim evans, May 16, 2007
    #4
  5. jim evans

    tomcas Guest

    Have you tried the readers on other XP computers? Many times the problem
    turns out to be a USB cable, port, hub, or driver problem. For instance
    , installing XP on older motherboards frequently fails to load the
    enhanced (2.0) drivers.
     
    tomcas, May 17, 2007
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.