Big problem with USB scanner : no icon and error message while it seems to be OK in Windows Control

Discussion in 'Scanners' started by franny, Jun 16, 2008.

  1. franny

    franny Guest

    Hello,

    I have a problem with my scanner (a new Canon CanoScan LiDE 90 just
    bought some days ago) : the deconnect icone in systray disappear some
    seconds after Windows 2000 starts and every attempt to scan fails : the
    carriage move a little, then I receive an error message saying there is
    a problem with scanner communication.

    I've checked in the control panel and the scanner appears without any
    problem (no yellow icon).

    I've tried to uninstall all, then reinstall and it remain the same.

    So, I've tried with another scanner (Packard Bell 1200 Diamond Plus) I
    had on another PC and it's the same behavior : icon at bottom right, in
    system tray area, apears just some seconds, the disappears and every
    scanning attempt finish with an error message.

    Does someone encountered the same problem : I have a real need to be
    able to scan and don't know what to do now ?

    Help !
     
    franny, Jun 16, 2008
    #1
    1. Advertisements

  2. franny

    Nick Wedd Guest

    Almost certainly not the right answer, but easy to test -
    disable your virus checker, then try.

    Nick
     
    Nick Wedd, Jun 18, 2008
    #2
    1. Advertisements

  3. franny

    Alan Meyer Guest

    I'm coming late to this issue. You might have already solved it, or
    returned the scanner, or thrown the computer out the Window and
    moved to the Yukon. But anyway, here are some thoughts.

    It appears that Windows is calling the device driver initialization
    routine and that routine is doing a whole bunch of things successfully,
    including putting the icon in the system tray. Then it runs into some
    kind of error and backs things out, or tells Windows that it has an
    error and Windows backs some things out (perhaps more likely).

    Since different scanners do this, the problem is clearly in your
    hardware or Windows, but as to what it is - that's hard to know.

    I recommend the following:

    1. Try plugging into a different USB port. Maybe there's a port
    problem.

    2. Look in all the event logs (on XP that's in My Computer/Manage/
    Event Viewer.) See if there are any messages that will give more
    clues.

    3. Compare registries.

    What I have in mind with number 3 is this. Export a copy of the
    registry on another computer. Then install the scanner there. Then
    export again and find the differences. Then compare what you see
    in the registry on the computer where everything works with what
    you see on the computer where it doesn't work.

    The reason I suggest that is that I once tried to install a scanner
    and couldn't get it to work. It turned out that the registry section
    for the scanner drivers was messed up. I copied that registry
    section from the computer that worked to the one that didn't
    work and, Voila! I was surprised that that worked, but it did.
    Backup the registry before you modify it.

    Good luck.

    Alan
     
    Alan Meyer, Jul 4, 2008
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.