Canon A510 problem - lens stuck, turns on for 10s then shuts off.

Discussion in 'Canon' started by rj, Apr 19, 2006.

  1. rj

    rj Guest

    Hi, I'm looking for advice on a Canon A510. I have had it for a couple
    months and have used it about 7 times and it has worked fine.

    The lens is stuck about 2 millimeters out, the lens protector shield
    thingies are about half open. I try to turn it on and the blue canon screen
    comes on for 10 seconds then it beeps 6 time quickly and shuts off.

    I can't remember exactly what happened but I may have quickly put in my
    windbreaker pocket while it was still on and just stood in there watching
    something for a few minutes so there may have been a bit of pressure against
    the lens but I don't think anything very significant. Or, I just put it
    down while still on for a few minutes, I can't remember.

    The manual says if the lens is stuck the battery cover or memory card slot
    doors may be open but I've checked they are closed. I tried putting new
    batteries in, checkrf they installed properly etc. but nothing helps.

    I'd appreciate any suggestions
    thanks
    rj.
     
    rj, Apr 19, 2006
    #1
    1. Advertisements

  2. rj

    Bill Funk Guest

    If you've only had it for a couple of months, it's still under
    warranty, right?
    If not, call Canon support, and ask them if they can give an
    *estimate* over the phone.
     
    Bill Funk, Apr 20, 2006
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.