D70 Firmware Won't Upgrade

Discussion in 'Digital SLR' started by Joe Makowiec, May 24, 2005.

  1. Joe Makowiec

    Joe Makowiec Guest

    I've downloaded the D70 firmware upgrade from Nikon a couple of times.
    I've unzipped it on two different computers. I've transferred the 'A'
    upgrade to the camera using a USB cable, and by removing the card and
    inserting it into a PCCard adapter. I've tried it with two different
    battery packs, both fully charged. I've used three different cards,
    including two on the approved list. When I try to do the upgrade, I
    follow this routine:

    - Menu key
    - Select 'wrench' (yellow) menu
    - Select 'Firmware version'
    - Select 'Update'; camera replies:
    A 1.01 > A 2.00 Update firmware?
    - Select Yes, press Enter
    Get message "Do not turn off camera etc"
    - Don't touch anything in this period of time
    Get message "Update Error"

    After power cycling the camera, it continues to work fine, but with the
    old firmware.

    Has anybody run into this? Any idea what I need to do to get it to
    upgrade?
     
    Joe Makowiec, May 24, 2005
    #1
    1. Advertisements

  2. Joe Makowiec

    Tom Scales Guest


    I'd try downloading it again. Perhaps the file was corrupt.
     
    Tom Scales, May 24, 2005
    #2
    1. Advertisements

  3. Joe Makowiec

    Owamanga Guest

    <snip>

    Try the reset button at the base of the camera - you'll probably loose
    all the CSM settings & curves etc, but maybe something there is
    causing a problem?

    Also, was A 1.01 the last version? I don't think it was. If not, try
    upgrading to the prior release of firmware, and then to this one.

    ...just guesses though..
     
    Owamanga, May 24, 2005
    #3
  4. Joe Makowiec

    Paul Furman Guest

    Are you using a microdrive rather than CF card? For some silly reason
    they don't allow microdrive.
     
    Paul Furman, May 24, 2005
    #4
  5. Joe Makowiec

    Ed Ruf Guest

    The US instructions also specifically stated not to copy the files to the
    card using a Lexar JumpShot, though I had no problems whatsoever.
     
    Ed Ruf, May 24, 2005
    #5
  6. Joe Makowiec

    ernie clyma Guest

    Try what Owamanga advised, mine wouldn't upgrade until a previous upgrade
    was done. Hope this takes care of your problem,
     
    ernie clyma, May 24, 2005
    #6
  7. Joe Makowiec

    Ed Ruf Guest

    Have you tried first reformatting the card in the camera?
     
    Ed Ruf, May 24, 2005
    #7
  8. Joe Makowiec

    larrylook Guest

    Make sure you put file in root folder of card. Don't put it in any folder
    that is on the card.
     
    larrylook, May 25, 2005
    #8
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.