Different approach on my UMAX ASTRA 6450 problem

Discussion in 'Scanners' started by Jethro, Jul 8, 2006.

  1. Jethro

    Jethro Guest

    I don't think I have asked this before.

    But I wonder - has anyone out there EVER gotten a UMAX ASTRA 6450
    Firewire scanner to work under WXP?

    Thanx

    Jethro
     
    Jethro, Jul 8, 2006
    #1
    1. Advertisements

  2. Jethro

    Grinder Guest

    I've only tried to get three UMAX scanners to work. From that
    experience I cannot say that any UMAX scanner has ever worked on any
    operating system. Crap, crap and more crap.

    Hopefully, though, my tangent will not jinx your efforts. Good luck.
     
    Grinder, Jul 8, 2006
    #2
    1. Advertisements

  3. Jethro

    Jethro Guest

    Hey! Thanks.

    I'll try it as soon as the Red Sox win and let ya know.

    Jethro
     
    Jethro, Jul 8, 2006
    #3
  4. Jethro

    Jethro Guest


    Well, the Red Sox won, but I don't think Jethro did.

    What a mess trying to download the compressed file(s).
    'MIME problem' is putting it mildly.

    I finally got

    vs376f-1.exe = 5.860M
    vs376f.r00 = 5.681M

    I recognize these as compressed RARs. and I got

    DISK1 = Folder = 1.01M = 32 files
    DISK2 = Folder = 1.18M = 14 files
    DISK3 = Folder = 1.56M = 16 files
    DISK4 = Folder = 2.18M = 8 files
    DISK5 = Folder = 1.31M = 13 files
    DISK6 = Folder = 1.75M = 19 files, 1 folder
    ENGLISH = Folder = 4.03M = 204 files, 2 folders
    FRENCH I ignored
    GERMAN I ignored
    MAILPACK = folder = 2.33M 20 files
    PROFILES = folder = 1.0M 12 files, 3 folders

    (I hope I got the above correct)

    I don't know if these are the right folders/files or not, BUT I
    searched all of them and do NOT find any occurrence of Astra 6400 and
    Astra 6500. 6400 and 6500 or any part thereof. So I think maybe I
    missed something. What do you think?

    Thanks Paul for your help

    Jethro
     
    Jethro, Jul 9, 2006
    #4
  5. Jethro

    Jethro Guest

    Thanks Paul.

    First of all, I apologize for not examining the file contents in the
    various files - I thought you suggested checking the fine 'names'
    themselves. My stupidity. I should have know better - but my glee
    over the Red Sox win suppressed my thinking cap.

    Yes the VSSETUP.EXE program installs Vistascan. In fact, it does just
    that okay ( no errors indicated anyway).

    I started over by removing the yellow-flagged entry under Imaging
    Devices in Device Manager and by removing all occurrences of Vistascan
    previously installed on my HDD. Interestingly, when I rebooted with
    the scanner powered on, WXP's PnP found the scanner as new hardware,
    and even though I cancelled out of any installation of that, the
    flagged entry in Device Manager came back. That surprised me. So be
    it, I then repeated the re- boot, this time trying to point to the
    drivers in our just-downloaded DISK folders. No change.

    I find no reference to '6450' or Firewire in DISK1 .inf files
    I find this in DISK2's UMAXUSD2.INF file:
    ;; SBP2
    %SBP2\ASTRA6400.DeviceDesc% =
    UMAXSBP2.Scanner,SBP2\UMAX&Astra_6400______&CmdSetId104d8
    %SBP2\ASTRA6500.DeviceDesc% =
    UMAXSBP2.Scanner,SBP2\UMAX&Astra_6500______&CmdSetId104d8

    I wonder what 'SBP2' is?
    I find that Google recognizes it as a ASTRA 6450 firewire-related URL
    at http://www.scanner-drivers.com/drivers/59/59340.htm
    which takes me to Driverguide for the same driver (astra6400_6450.exe)
    that I downloaded and installed unsuccessfully before and which looks
    to be the same folders/files that are in the current RAR package.

    I find this in DISK3's UMAXUSD2.INF file:
    ;; SBP2
    %SBP2\ASTRA6400.DeviceDesc% =
    UMAXSBP2.Scanner,SBP2\UMAX&Astra_6400______&CmdSetId104d8
    %SBP2\ASTRA6500.DeviceDesc% =
    UMAXSBP2.Scanner,SBP2\UMAX&Astra_6500______&CmdSetId104d8

    It does look like MAILPACK is concerned with e-mailing, so I see no
    reason to sweat that.

    I see 4 interesting filenames in PROFILES\SCANNER (e.g. AS6400R.ICM).

    I tried re-installing the scanner, pointing to DISK3 vice DISK1 (I
    think I had done all this before). Same results.

    I still am waiting to hear from ANYONE who actually has been able to
    get the 6450 to work under WXP. No responses on that one. Until I
    do, I will continue to wonder if it ever did.

    Thanks again

    Jethro
     
    Jethro, Jul 9, 2006
    #5
  6. That's as it should be and if the support is there in XP it would install it.
    That would be normal. XP is now aware of the device, but it is not installed
    correctly.
    Needs to be done a different way.
    Paul expalined that above - Serial Bus Protocol 2 for Firewire.
    That one looks Ok and, if the new one is identical, you should be set to go.
    Those folders Disk1, Disk2, ... should all be together in some other folder. The
    name doesn't matter. Double-click on that file vssetup.exe in the Disk1 folder
    and let it install that support for the scanner.

    Then remove that device in Device Manager just like you did above. Then re-boot.
    XP will again see a new device and should install it without intervention on
    your part because you have already installed support.
    Don't worry about the extras. Scanners often come packaged with additional
    utilities and software.

    Bob
     
    Robert Heiling, Jul 9, 2006
    #6
  7. Jethro

    Jethro Guest

    I just wanted to try installing Vistascan first, without any error
    entry in Device Manager. Didn't happen.
    Dang - I missed that.
    They are, and as I said, Vistascan seemingly installed okay, as
    before.
    However, now I cannot uninstall the Device Manager entry for the
    scanner. It says it 'may be required to start up the computer'. I
    find no evidence of scanner app in Task Manager. I can only disable
    it, and I did. Re-boot changed nothing - it booted automatically and
    the Device Manager entry is still sitting there, disabled.
    Yes - I figured that.
     
    Jethro, Jul 9, 2006
    #7
  8. It would have hopefully included driver support also.
    Did it still have a yellow exclamation point? I guess we should have uninstalled
    it first before installing vssetup.exe
    There won't be unless you start one except for the one in systray if there is
    one.
    Of course. I don't understand the reason for disabling it though since the
    motive is to get it working. Does it still have a yellow exclamation point? Has
    any icon been added to systray? Is there an option to update the driver in
    Device Manager? If there is and it was still yellow, then update the driver
    after re-enabling!! You will need to know where those .inf files wentas you may
    be requested for them. Might want to search for them in advance and they should
    be in windows/inf or a subfolder.

    Bob


    Bob
     
    Robert Heiling, Jul 9, 2006
    #8
  9. Jethro

    Jethro Guest


    That's what I tried to say - namely that I could NOT uninstall the
    driver from Device Manager (it said it was needed for boot up), so to
    get it out of the picture, I disabled it, and it remained that way.
    until I re-enabled it, when I get the yellow flag again. When I try
    to update the driver in Device manager, I point to the folder DISK2
    (I know where the folders and their .inf files are), but I keep
    getting a failure with error message from Device Manager that there is
    a problem with the install.

    You know, I really think that this danged scanner is simply bad - i.e.
    that the scanner simply is broke. If so, I (we) am beating a dead
    horse. The scan-light does come on and goes to home position when I
    power it on though.
     
    Jethro, Jul 9, 2006
    #9
  10. I understood you up to that point.
    And you lost me there.
    Ok. So you do get the yellow. Have you re-booted with it enabled by chance just
    to see what happens?
    Then you should have pointed there if you know and not to DISK2. You're finished
    with those! It's wherever vssetup.exe installed them on your system. Considering
    what Paul mentioned as the contents of UMAXUSD2.INF, it should be wherever that
    file is located, in a subfolder of Windows. XP may find it on its own or Windows
    might prompt you by filename.
    Try again
    It hasn't had a real chance as yet.

    Bob
     
    Robert Heiling, Jul 9, 2006
    #10
  11. Jethro

    Jethro Guest

    Yes - it remains flagged.
    Hmmm

    vssetup.exe (from the setup DISK1 folder) executed without error and
    created c:\VSTASCAN with:

    copier32.exe
    dragdrop.exe
    OpManual.pdf
    readme.txt
    test32.exe
    uninstal.exe
    uninstal.ini
    Vista32.exe
    vsaccess.exe

    plus a folder = mailpack

    I see NO file by the name of UMAXUSD2.INF therein. That is why I
    pointed the re installer to DISK2 and then to DISK3, two folders that
    do contain UMAXUSD2.INF, Both times I got the error that driver
    re-installation failed.
    I hope you're right

    I do feel bad that I can't seem to describe accurately what I am doing
    and how I am doing it, but bear with me please.

    Jethro
     
    Jethro, Jul 9, 2006
    #11
  12. Good grief man! That's not the *Windows* folder is it? VSSETUP.EXE installed
    files all over the place! Now please go into My Computer and navigate to your C:
    drive and the Windows folder. Then do a Search for files named UMAXUSD2.INF.
    Just make note of which folder it is in. Then try to Update the driver.
    Of course you got an error and it will never work that way.
    Ok, but try harder to understand what is written to you.

    Bob
     
    Robert Heiling, Jul 9, 2006
    #12
  13. Jethro

    Jethro Guest

    Good Good Grief Grief man man!! :<)

    I DID a FULL C drive scan in Windows Explorer for UMAXUSD2.INF and it
    did not show up under Windows or anywhere else other than where I
    said. So, obviously, this must be my problem. Since my install,
    using vssetup.exe, did not place that inf file there - then I have to
    discover why it did NOT.

    BTW


    http://scanner.free-driver-download...-Astra-6400-6450-VistaScan-3.76-Firewire.html

    says (in part):

    UMAX Scanner Astra 6400/6450 VistaScan 3.76 Firewire Windows
    9x/ME/2000/XP.

    Install VistaScan 3.76 and reboot your PC. In case the scanner does
    not appear in the Device Manager as "UMAX 1394", double cklick its
    entry and update the driver referring to
    Disk2 folder in the directory <<<================
    where you expanded the VistaScan driver (or Umax Driver CD) as driver
    source. Ignore the warning about the missing cetrificate for WindowsXP
    and continue the installation. As VistaScan is Windows 2000
    compatible, it also works properly unter WindowsXP.

    Hence my doing what I did. :<(
     
    Jethro, Jul 9, 2006
    #13
  14. That had only been my guess as to the name and I was certain that they would
    leave a .inf file hanging aroung. I finally pulled those files down and expanded
    the Disks and see that it uses the same Twain driver setup that my scsi scanner
    uses. No surprise there actually. There definitely are Umax dll's in the driver
    though and XP needs to be told about that somehow.
    Now you tell me.<g> But fair enough, if that's what they say to do.

    If you turn the scanner off and re-boot, you may be able to remove the driver.
    If that works, then turn it back on and re-boot. XP should find it and install.

    Bob
     
    Robert Heiling, Jul 10, 2006
    #14
  15. Jethro

    Jethro Guest

    As you know, the software is no longer downloadable from this site.
    But of course, I have it from the other source.
    I did this.
    Doesn't show any of the following in Safe Mode:
    -----------------------------------------------------------------------
    I rebooted in normal mode, and as before I cannot uninstall because
    the system will not let me (says it is needed during boot-up)
    I did this.
    I did this.
    I did this.
    I did not see this folder.
    Yes. That sounds right.
    It does not say to leave Safe Mode and re-boot normally, but I did -
    then did the above.
    Just like before, it does not come up. Scanner is not recognized.
    Device Manager has the yellow-flagged entry for the scanner.

    Yes, but it is flagged yellow. The entry reads:
    UMAX Astra 6400 IEEE 1394 SBP2 Device
    Under HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Enum\1394
    I found UMAX&Astra_6400____________ (sic) but no &CmdSetId104d8
    In fact, I find no CmdSetId104d8 in the Registry at all.
    I add the line

    %SBP2\ASTRA6400.DeviceDesc% =
    UMAXSBP2.Scanner,SBP2\UMAX&Astra_6400______

    to the subject .inf file and tried to re-install the scanner driver in
    Device Manager. I still got

    'There was a problem installing this hardware'

    I even more suspect the scanner may be bad.
     
    Jethro, Jul 10, 2006
    #15
  16. Jethro

    Paul Guest

    You need to find a piece of software that can talk
    to a 6400. Maybe this will involve Linux and some
    kind of open source software. But there has to be
    something, that can do more than just extract
    Astra_6400______ .

    The UMAX instructions mention a "UMAX test program".
    Did anything like that pop up ? If you look around
    the install folder, is there anything with a filename
    suggestive of a test program ?

    Paul
     
    Paul, Jul 10, 2006
    #16
  17. Jethro

    Jethro Guest

    I'll look a little.
    Yes there is - it is called test32.exe and is part of the package
    installed by vssetup.exe in the aforediscussed (now that's a word!)
    folder DISK1. test32.exe causes execution of a 'UMAX Scanner Test
    Program'.

    When I run it, it tries to access the scanner, but fails to find it
    ('error message 'scanner access fail').

    Jethro
     
    Jethro, Jul 10, 2006
    #17
  18. Jethro

    Jethro Guest

    A shot in the dark -

    Has anyone out there EVER gotten a UMAX ASTRA 6450
    Firewire scanner to actually work under WXP?

    Thanx

    Jethro
     
    Jethro, Jul 10, 2006
    #18
  19. That's looking like it installed and 'only' has some problem. Apparently the
    "6450" is just an external identification and it is still technically a 6400 at
    heart. It might be helpful to know what modules are listed under Details for
    that Driver. Also, can you search and find a SCSISCAN.SYS anywhere in the
    Windows folder?

    And planning ahead:
    If you have a DVD burner and use software like Nero or similar installed, then
    you would already have aspi installed. If not, you are going to need it. Get
    aspichk.exe from the website at: http://radified.com/ASPI/forceaspi.htm
    Run that to check the current condition of aspi on your system.
     
    Robert Heiling, Jul 10, 2006
    #19
  20. Jethro

    Jethro Guest

    Yes - scsiscan.sys exists at c:\windows\system32\drivers.
    Yes I do - Nero. but I found aspichk under a different CDRW
    application, so I downloaded and executed the file at
    http://radified.com/ASPI/forceaspi.htm
    After re-boot (as per instructions), I did another search for
    aspichk.exe. I see it nowhere additional except of course the
    downloaded file. I tried to re-install the scanner driver anyhow,
    with the same negative results.

    Oh well....

    Thanks again. Please don't give up on me. I still have not been able
    to get anyone to admit that they ever got this scanner to run on WXP!

    Jethro
     
    Jethro, Jul 10, 2006
    #20
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.