Different approach on my UMAX ASTRA 6450 problem

Discussion in 'Scanners' started by Jethro, Jul 8, 2006.

  1. You seem to have forgotten the list of files under Driver Details. :)
    Sounds good!
    aspichk.exe is just a utility that brings up a graphics display (or should). It
    doesn't install anything.
    Hopefully with the original .inf and not the one you modified. Also hopefully
    showing a IEEE 1394 SBP2 Device afterwards that will reveal a list of files in
    the Driver Details tab.
    Why would they be here if they didn't have any trouble? They're merrily scanning
    away. <vbg>

    Bob
     
    Robert Heiling, Jul 11, 2006
    #21
    1. Advertisements

  2. Jethro

    Jethro Guest

    I don't see a file list under 'details' for the driver in Device
    Manager. I see a pull down window with several selectable's the first
    of which is 'Device Instance Id'. I must be in the wrong place.
    Where?
     
    Jethro, Jul 11, 2006
    #22
    1. Advertisements

  3. I run Win2k and linux on this machine and Win2k is close to XP but not exact in
    the way that is done. So I went upstairs to the XP machine as I had done earlier
    to make sure the info was available. No UMAX on that one, but no matter. This
    time I mentally noted the details. You've obviously been getting to Device
    Manager, so starting with that screen up, I choose any device, right-click and
    select Properties. Then click the Driver tab. Then click Driver Details. There
    will hopefully be a list of files.

    The exercise we're going through now will be shooting at a moving target and a
    waste of time if this isn't a fresh install using the original installation
    files.

    Bob
     
    Robert Heiling, Jul 11, 2006
    #23
  4. Jethro

    Jethro Guest

    Yes, I am operating within Device Manager, which has three
    scanner-related entries:
    1 - A firewire entry:
    'IEEE 1394 Bus host controller' under which is:
    'VIA OHCI Compliant IEEE 1394 SBP2 Device'
    which it says is working properly.
    2 - A Imaging Devices entry:
    'UMAX Astra 6400 IEEE 1394 SBP2 Device'
    WHICH IS FLAGGED YELLOW! and shows that
    'the drivers for this device are not installed (code 28)'
    and which when I try to re-install the driver, it says it failed,
    saying:
    'THERE WAS A PROBLEM INSTALLING THIS HARDWARE'.
    3 - A 'SBP2 IEEE 1394 Devices' entry under which is:
    'SBP2 Compliant IEEE 1394 Device'
    which it says is working properly.

    For the yellow-flagged entry, I was going to Properties>Details
    yesterday, which was wrong. Now I am at Properties>Driver>Driver
    Details. It says:
    'No driver files are required or have been loaded for this device'.

    I checked the other two Device Manager driver entries, and sure enough
    there are file names there under, 5 under the first,
    1394bus.sys
    asp1394.sys
    enum1394.sys
    nic1394.sys
    ohci1394.sys
    1 under the third.
    sbp2port.sys

    Does all this show anything revealing?
    I agree. But I did just that, I think. I began yesterday's efforts
    by removing all prior work (except removing the driver from Device
    manager - which I could not do for some reason), and then re-did
    everything, including trying to re-install the driver in Device
    Manager.

    Thanks again

    Jethro
     
    Jethro, Jul 11, 2006
    #24
  5. Windows thinks you enjoy being lied to like that?
    At least we know the extent of the damage.

    I'm still scratching my head over that one. aspichk.exe doesn't ask for a
    re-boot. Are we talking about the same module or did you get one with a
    different spelling?
    I guess that it's time for a little hacking. There are some readme notes I left
    in my Windows from when I was going through this same hassle with my system and
    maybe the following will work for your system. Go to Disk2 on that installation
    set and locate the file UMAXUSD2.INF. Place a copy of it in your C:\Windows\inf
    folder. Rename it to umax.inf and then right-click on it and choose the Install
    option. Our next step will be determined by what happens then.

    Bob
     
    Robert Heiling, Jul 11, 2006
    #25
  6. On second thought, re-boot first after the rename and before clicking that
    Install. It may not make any difference, but no harm in booting.

    Bob
     
    Robert Heiling, Jul 11, 2006
    #26
  7. Jethro

    Jethro Guest

    GOOD MORNING!

    Wouldn't be the first time, would it?
    Easy for U to say.
    I downloaded 179KB file ForceASPI_v17.zip from
    http://radified.com/Files/ForceASPI_v17.zip and un-zipped it to get:
    3 folders
    WIN9X
    WINNT
    HTML
    plus 8 files including 112KB file aspichk,exe and instaspi.bat.
    I executed the latter DOS batch file and it seemed to run okay, after
    which it actually says to reboot your PC to 'make the changes active',
    and to 'press continue' to do it - which I did.
    Hence the re-boot.

    The batch file showed four files added to c:\windows:
    winaspi.dll
    wowpost.exe
    winaspi32,dll
    aspi32.sys

    plus 'add registry settings'
    'Done!'

    Anyway - after re-boot. I do not see any aspichk.exe except for the
    one in the unzipped folder that had the batch file I executed above.
    When I execute it, I get a window showing that 'version 4.6 of ASPI is
    properly installed', and is 'fully operational' and shows all four
    files listed above (winaspi.dll etc). Again, just now, I tried to
    re-install the scanner driver in Device Manager. and it failed same as
    before.
    Done. I renamed it too,
    Done. The screen just 'blinked', but did not show a window or message
    or anything else. I will remain in this position until I hear back.

    Thanks

    Jethro
     
    Jethro, Jul 11, 2006
    #27
  8. Jethro

    Jethro Guest

    I just spotted this post. I re-booted, then executed an install of
    umax.inf with same non-results. I.E. the screen blinks and that's
    all.

    Jethro
     
    Jethro, Jul 11, 2006
    #28
  9. Oh oh! That's not aspichk.exe.
    I hope that hasn't screwed anything up. Probably not, but I hope Nero still
    works properly. If that overwrote Nero's special aspi module then it will break
    Nero. The aspichk.exe is just a little ways down his webpage in large bold
    lettering and shows an example of what it looks like when executed. The
    instructions for downloading just that single file are right there. I had no
    idea that telling you to download aspichk.exe would be translated into the above
    actions. :(
    That's what it supposed to do and fine! It's just that we will never know what
    its status had been previously.
    I've pretty much despaired of being able to run a controlled test.
    Check Device Manager to see if it worked!
     
    Robert Heiling, Jul 11, 2006
    #29
  10. Check Device Manager!

    If it didn't work that way, then there are some other things to try. The first
    would be to go into Device Driver etc. and try to Update the driver.

    Failing that, you'll need to remove that thing somehow. Can't you just unplug it
    and re-boot and then remove it? We need to have Windows see it as a new device
    and attempt to install it now that we have the umax.inf in there.

    Bob
     
    Robert Heiling, Jul 11, 2006
    #30
  11. Jethro

    Jethro Guest

    Did that - as I have been saying it returns an error that 'there was a
    problem installing the hardware'.
    I hasn't been letting me do that - says it needs the driver to boot
    the system. If I come up in safe mode or with scanner off - the
    device manager item is not there at all - so I can't deal with it that
    way.

    Jethro
     
    Jethro, Jul 11, 2006
    #31
  12. Jethro

    Jethro Guest

    That's why I specified the file size. I thought that to be a
    possibility. It would explain wouldn't it?
    Nero seems to still run okay.

    No - I still have the yellow flag.
     
    Jethro, Jul 11, 2006
    #32
  13. Jethro

    Jethro Guest

    I tried removing it again, and this time it let me. When I re-booted
    it recognized the need to install new hardware, but when completed
    (with the error msg), I still get the flagged entry in Device Manger.
     
    Jethro, Jul 11, 2006
    #33
  14. Did it simply just install or were you prompted for any input? If there were
    prompts, what were they? and what was your reply?

    Bob
     
    Robert Heiling, Jul 11, 2006
    #34
  15. Jethro

    Jethro Guest

    On top of everything else now, I have lost my cable ISP again.
    Happened two days ago - it came back up after several hours - their
    techie said my external modem was running at peak and was about to
    fail. Don't know if that is so - but it is happening again dang it.
    It turns on and starts to come up but stops half-way. So I am stuck
    using my dial up backup ISP (Netzero) and will have some difficulties
    maintaining good ISP connection since I have to save my marriage by
    not tying up the phone line.

    Having said that - to answer your question.

    It was the normal WXXP PnP install new hardware scenario, wherein I
    point to the downloaded DISK1 (or DISK2) folders for it to find the
    necessary driver(s). As before, it said it has a problem installing
    the hardware. So, being able to uninstall the driver in Device
    Manager had no effect.

    Jethro
     
    Jethro, Jul 11, 2006
    #35
  16. Sounds like they're having problems with the lines in your area. Have there been
    storms there recently?
    You followed the same process as before, so got the same results as before. But
    we had made a hack since then. Start over by removing it again and re-booting.
    Point the wizard to C:\Windows\inf this goaround. If it wants a specific file
    then give it the umax.inf that we put in there. Keep your fingers crossed.

    Bob
     
    Robert Heiling, Jul 11, 2006
    #36
  17. Jethro

    Jethro Guest


    No My ISP is back up again. Obviously the problem id not on my end.
    This time it won't let me uninstall it from Device Manager, just like
    before. It only let me do that that one time. Its got mind of its
    own in this respect I guess. As far as pointing the wizard to the
    umax,inf file is concerned, the wizard only lets me point to the
    c:\windows\inf folder, not to individual files therein.

    BTW, my cable ISP is alive again. Who didn't know that would happen?

    Jethro
     
    Jethro, Jul 11, 2006
    #37
  18. Did I miss something or haven't we tried that approach in the Update Driver
    scenario?
    It must be because you cleared your browser cache & cookies like they told you
    to.<LOL>

    Bob
     
    Robert Heiling, Jul 11, 2006
    #38
  19. Jethro

    Jethro Guest

    Sure did. To no avail.
    I did not clear my browser cache nor did I delete any cookies nor did
    they tell me to do that. How did U get that idea? Did I mis-state
    something again?

    Jethro
     
    Jethro, Jul 12, 2006
    #39
  20. Then we can only hope that you find the magic trick that enabled you to delete
    it last time. The test for the current hack is to get plug & play to find the
    new device and then point the wizard at C:\Windows\inf where we have a proper
    inf file for it - umax.inf. Have fun.
    Nope. Just joking about something I thought you would find familiar. My own
    ISP's techs put you through that routine for any connection problems, so I
    figured yours did too.

    Bob
     
    Robert Heiling, Jul 12, 2006
    #40
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.