DMA will not set

Discussion in 'Video Cameras' started by jpraskac, Aug 5, 2006.

  1. jpraskac

    jpraskac Guest

    Hello,

    I am having an issue with my IDE Hard Drives staying in DMA mode. I
    have the option in the drop down box to set them in DMA, but only "PIO
    Mode" displays in the Current Transfer Mode window. I have the original
    30GB Drive and a new additional 160GB 7200rpm Western Digital drive.
    I've seen advice saying to delete the drives from Device Manager, but I
    am uncertain on how to do that, and what effects that might have on the
    system.

    Any help is greatly appreciated, I'm trying to get my performance up
    for capturing, and this is the most common advice I've seen and I
    cannot seem to get it to work.

    Thanks
     
    jpraskac, Aug 5, 2006
    #1
    1. Advertisements

  2. jpraskac

    Dean Guest

    Try going in to the BIOS and re-detect the drives. If that fails try
    upgrading the BIOS, if an update is available.
     
    Dean, Aug 5, 2006
    #2
    1. Advertisements

  3. jpraskac

    Mark A Guest

    If you've installed the Intel accelerator software that will disable
    DMA selection as it takes that over with its own drivers.

    Regards

    Mark
     
    Mark A, Aug 5, 2006
    #3
  4. I am having an issue with my IDE Hard Drives staying in DMA mode. I
    When a certain number of read errors are detected on an IDE bus,
    Windows has a habit of kicking it down a notch, eventually to PIO
    only. The easiest way of resetting it to completely remove the IDE
    controllers (not just the individual drives) in Device Manager. They
    will re-install after a reboot.

    There may also be an issue with another device on the same bus. In
    the olden days, a slower device on (say) the secondary would drag a
    faster device on the primary down to its speed. This is not the case
    on modern systems, and I hardly feel that your new drive would be a
    slow device! But check its jumper settings anyway. Odd things can
    happen if the master/slave/cs setting is inappropriate.

    But first off, delete and re-install the IDE controllers.
     
    Laurence Payne, Aug 5, 2006
    #4
  5. jpraskac

    News Will Guest

    Replace the 30Gb drive.
    I suspect it doesn't support DMA.
    Both drives on the same cable will drop to the lower speed.
    Also you should have an 80 wire cable.
     
    News Will, Aug 5, 2006
    #5
  6. I guess it's also time we found out what computer, what operating
    system, was the 30GB drive happily running DMA before the new drive,
    is the new drive on the same IDE cable, is it a 40 or 80 way
    cable....have I missed anything?


    And whether removing and re-installing the IDE controllers worked? Do
    I detect we're scared to try this?
     
    Laurence Payne, Aug 5, 2006
    #6
  7. jpraskac

    Afterburner Guest

    The Computer is a Dell 4600, I think it was July 2003, both drives are
    on the same cable, as the other cable carries 2 CD drives. I could
    probably put each drive on the same cable as a CD Drive, but would this
    create problems? I'm not sure but I would guess the cable the drives
    are on are 80 since it came with the new drive, and the OS is Win XP
    Home. I upgraded the BIOS today and I had no option to redetect the
    drives, I have not yet removed the Controller's from Device Manager, I
    will do that now, if that does not work I will change the cables around
    as I said before.

    Thanks for the assistance so far
     
    Afterburner, Aug 5, 2006
    #7
  8. Also, if it's an 80-way cable, set the jumpers on both drives to cs
    (cable select). If a 40-way cable check the new drive is set to Slave
    (assuming you're booting off the old drive).

    (If the cable's the same as the one to the CD drives, it's 40-way. If
    it's got twice as many ways, it's 80-way. Probably.)

    It is possible that there are settings in BIOS to enable IDE features
    separately for IDE 0 and IDE 1, for primary and secondary. Check
    through all pages in BIOS setup.
     
    Laurence Payne, Aug 5, 2006
    #8
  9. jpraskac

    Afterburner Guest

    Ok, having reinstalled the IDE Controller the Drives are on, now in
    Device Manager it shows Device 0 is in DMA Ultra Mode 2, and Device 1
    is still in PIO Mode. However my main problem of capturing is not
    resolved (Playback is perfect, but during capture it stutter's and
    drops frames) The New drive is set to slave, the older being Master.
    How exactly can I tell if the cable is 40 or 80 way?
     
    Afterburner, Aug 5, 2006
    #9
  10. See my previous reply.

    I think it's time to have a look in BIOS setup now. Sometimes when a
    computer is supplied with a certain selection of devices, others are
    disabled or not fully enabled in BIOS. Look for a DMA-Auto setting
    for all IDE channels.
     
    Laurence Payne, Aug 5, 2006
    #10
  11. jpraskac

    Afterburner Guest

    Hey Thank you so much, I set all the IDE (even the ATA) channels to
    Auto, the ATA didn't detect any devices obviously haha, but the IDE
    devices are now in DMA Ultra mode 5!!! Both Drives that is, one last
    quick question, I have an external Seagate 120GB HDD on USB, can I
    control that similar to make sure I'm getting all the speed out of
    that?

    Big Thank you!
     
    Afterburner, Aug 5, 2006
    #11
  12. No.
     
    Laurence Payne, Aug 5, 2006
    #12
  13. jpraskac

    Afterburner Guest

    Alright, finally I do have to say that during capturing video is smooth
    which is great, but I still get an unknown recorder error, but I need
    to take that problem to a Premiere group, Thanks again for the help
     
    Afterburner, Aug 5, 2006
    #13
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.