Does Epson 4490 work with XP Media Center Edition?

Discussion in 'Digital Cameras' started by Bob M, Nov 7, 2006.

  1. Bob M

    Bob M Guest

    Has anyone here been able to get the Epson Scan software to run on this
    operating system? My scanner runs OK on an older laptop running Windows XP
    Home Edition.

    Perhaps the most informative error message I get is from Photoshop, bundled
    with the scanner.
    When I try to "Connect to Scanner or Camera", I see a message:
    "Could not open the TWAIN source. Make sure there is a valid source for
    your scanner in the TWAIN directory in the Windows directory."

    I wonder if there is a problem here. There is no TWAIN directory in Windows.
    There is only a TWAIN_32 directory.

    I also see 4 files in the Windows directory called Twain.dll, Twain_32.dll,
    Twunk.exe and Twunk_32.exe. Should these files be there?

    I have called Epson for a half hour toll call and got nowhere. They did reply
    to one email, but problem is not solved yet. I was just wondering if anyone
    else has gone through this problem.
    Bob M, Nov 7, 2006
    1. Advertisements

  2. Bob M

    Bob M Guest

    Well, yes, as a matter of fact I was able to get it to work.
    It has taken only 6 days. Today I was at it for several hours, making 12 pages
    of handwritten notes.
    This has been one of the worst installations I have yet come across.
    I searched the web and groups for the various error messages, and found
    several people with a similar problem, but none of their solutions worked for
    One major complaint I have is the lack of informative error messages. It is
    one of those catch-22 things. A good programmer will anticipate many possible
    combinations, and write code that works in all situations. A good programmer
    will include copious error messages. Specifically, if he is expecting a file,
    ..dll or whatever, to be at a certain location, the message will say what he is
    looking for. Not a generic "Cannot start.." message like I have been looking
    at for the past week. The opposite of the good programmer will write code that
    only works on the machine he developed it on, and will include very few error
    messages. Of course, his code is the one that needs the error messages.

    In my case it relates to encryption. I have a few folders on this computer
    that are encrypted. By itself, that system works very well. But about a month
    ago I found that the Kodak Easyshare software was not written properly to deal
    with encrypted files. Most other programs I use do manage to deal with it.
    That is a bad reflection on Kodak.

    I do not know the exact sequence of what went wrong with the Epson install,
    but I noticed that some of the files that were installed were encrypted. I
    don't understand why this is so, as they were not in the folders which I had
    encrypted. I noticed that some files, such as the update .exe file from epson
    wound up encrypted, as do shortcuts that I create. I have a question into the
    WindowsXP newsgroup about this.

    Uninstall does not really remove all of the files which were installed. This
    causes problems when you really need to get rid of them. I had to open up the
    ..CAB files with winzip to get the names of about 56 files which the
    intallation scattered about the hard drive. Then search for each one, and
    delete it.

    There is no option to overwrite the files at installation. This could have
    saved me hours of time. The checkbox that mentions overwriting when you
    execute the downloaded .exe refers only to the files which typically go to a
    folder named c:\epson11975... etc. These can be overwritten, but when you
    execute the setup program in that folder you have no choice about overwriting.
    Hence the need to search and destroy.

    Curiously, many of these encrypted files were zero bytes in length. I don't
    know what caused that.

    Along the way, I found that you not only have to run the Control Panel to
    uninstall the software, but you need to use the Device Manager, while the
    scanner is plugged in, and uninstall the scanner there also.

    This whole installation has been Horrible. I just hope this lengthy message
    can save someone else these many frustrating hours.

    To do a proper installation, I created a new user with Administrative
    priveleges, but no encryption. This is what finally worked. (But it did not
    work until I manually deleted the 56 files and re-re installed).
    Bob M, Nov 8, 2006
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.