Epson 1660 scanner TWAIN / unknown device problem

Discussion in 'Scanners' started by Nicolai Michel, Jan 20, 2004.

  1. When I initially installed an Epson Perfection 1660 scanner everything seemed to
    work fine. The next day, however, the scanner no longer worked. I get errors
    saying there is a problem with the TWAIN system. I've tried installing the
    latest drivers. I've tried uninstalling everything and reinstalling from the CD,
    but this hasn't helped. The scanner always shows up as an Unknown Device in
    Device Manager, rather than as an Imaging device.

    Windows 2000 SP4. NEC-chipset USB 2.0 PCI card.
    The scanner works fine on a different computer.

    Any ideas?


    Nicolai Michel

    Remove NO.SPAM from my address!
    Enlevez NO.SPAM de mon adresse!
     
    Nicolai Michel, Jan 20, 2004
    #1
    1. Advertisements

  2. Nicolai Michel

    Bill Guest

    Hi Nicolai,
    I was having same problem and more with this NEC usb 2.0 card and Epson
    1660 scanner in XP Pro. I have messed with it for 2 weeks now. I'm not sure
    how you handle it in Win 2000, but I followed Epson's web page support and
    driver download instructions. It was still giving me problems till I turned
    off Windows Acquisiton Services.
    Microsoft released a patch for usb 2.0, but it's as flaky as it's operating
    system. Good luck with it and I hope this helps in some way.
    Bill
     
    Bill, Jan 20, 2004
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.