Epson Scan Fails to Load for Perfection 3170

Discussion in 'Scanners' started by dc, Nov 29, 2004.

  1. dc

    dc Guest

    Since about the time I installed SP2 for Windows XP I have been unable to
    use my Epson 3170 scanner. When I attempt to load Epson Scan it crashes
    immediately after the splash screen appears with the standard Windows
    exception message "escndv.exe has encountered a problem and needs to
    close".

    I have removed all software components for the scanner--drivers and
    programs--a number of times and attempted a clean reinstall of Epson Scan
    1.22a from the original CD. I have also tried the new version of Epson Scan
    from the Epson website (v2.34a). Both fail with the same result after the
    splash screen appears.

    Epson email support has thus far proved useless and has only recommended I
    try what I told them I had already attempted... a clean reinstall.

    I have tried searching for some answers on the NewSoft website but didn't
    see anything of use. I believe they are only responsible for creating the
    Smart Panel software package, which I am not using. It is the Epson Scan
    module that is failing when loaded.

    Anyone have any solutions to this?

    tHANKS,
     
    dc, Nov 29, 2004
    #1
    1. Advertisements

  2. dc

    dc Guest

    I didn't find one.

    I did however manage to fix the problem through further deliberate
    correspondence with Epson. I'll outline what they suggested here in case
    anyone else experiences this problem in the future.

    1: uninstall the scanner from the Device Manager and uninstall Epson Scan
    from the Add/Remove Program control panel. (did this part before)

    2: search for and remove any of the follow files from the HD:
    Twain.log, Twain001.mtx, Twunk001.mtx, Twunk002.mtx, Twunk003.mtx

    3: remove the Epson directory from C:\WINDOWS\TWAIN_32\

    4: remove the Epson Scan group from the Windows registry under both
    HKEY_LOCAL_MACHINE\Software\Epson\
    HKEY_CURRENT_USER\Software\Epson\

    5: reboot and reinstall Epson Scan

    It's probably the deleted registry key that fixes the problem, and no
    doubt the New Soft registry tool does just that... if you can manage to
    find where it is hidden away.
     
    dc, Nov 30, 2004
    #2
    1. Advertisements

  3. dc

    Ron Guest

    Well, I had a similar problems because of two things: There was other
    scanner software on my computer which conflicted with Epson's (in my
    case it was Canon's, which I think you can reload AFTER the Epson if for
    any reason you wanted to do that) and I plugged in the USB cable BEFORE
    loading the software. Make sure that cable is under your desk and not in
    your computer. Unfortunately, the error messages are not very specific.
    Incidentally, when I had my problems the Epson help desk person was
    great, and she indicated I was not alone. Hope this helps a bit.
     
    Ron, Dec 15, 2004
    #3
  4. dc

    RAF_Bruiser Guest

    I realize this thread is several months old - but I have use it to solv
    my problem with the Perfection 3170 - which is nearly identical to wha
    has been described at the beginning of the thread. Epson, by the way
    told me to have the scanner serviced. Newsoft never replied to m
    request for help. The only other thing I will add is a tip I got fro
    Newsoft's site that mentioned files with .dsc suffix (usually fro
    digital camera software).

    My fix - all of the above concerning uninstalling and registry purging
    followed by searching and removing .ds and .dsc files. The offendin
    file it appears in my system was called wiatwain.ds, probably came a
    part of a Cannon suite of digital camera apps. I re-installe
    EpsonScan only (not smart panel, etc). So far it works fine.

    I was really upset with Epson telling me to have the hardware service
    - because I really didn't think it was hardware related. I eve
    installed the 3rd party demo of vuescan, and it worked fine - I jus
    didn't want to spend the money on another app when the one that cam
    with the hardware should work!
     
    RAF_Bruiser, Mar 30, 2005
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.