Gradient banding Photoshop CS.

Discussion in 'Photoshop' started by Alastair Grant, Mar 2, 2005.

  1. I've just sprouted a very annoying problem with Photoshop CS (running on
    Windows 2000).

    When I use the gradient tool I get banding. Simple enough, but the
    problem exists exclusively in Photoshop. I'm running in 32-bit colour
    (GeForce gfx card). When I switch to ImageReady there is no banding.
    When I save to web and get the previews, it's fine (including the original).

    It is only the workspace of Photoshop which has this banding.

    I have tried altering my colour profile, and even disabling them - but
    this doesn't improve anything (although some profiles make it worse). I
    have tried deleting my settings file to see if it was an odd side effect
    of something, but no.

    I'm really stuck on this one. I could happily blame something else if
    it happened on everything, but as it's only on files open in Photoshop
    it's got me very confused.

    A saved file (which appears fine in the save preview, or any other
    application) will look wrong in Photoshop once reopened.

    Does anybody have any suggestions to solve this?

    Thanks,

    Alastair.


    --
    http://www.wireplay.co.uk/
    http://www.aligrant.com/

    "Never be ashamed of not knowing a
    thing, but always be ashamed of not
    wanting to know."
     
    Alastair Grant, Mar 2, 2005
    #1
    1. Advertisements

  2. I have no idea if this will be visible on other people's machines, but
    if it is you will see that the right hand image is fine, and the left is
    banded (although both the same file):

    http://www.aligrant.com/tmp/gradient.png

    --
    http://www.wireplay.co.uk/
    http://www.aligrant.com/

    "Never be ashamed of not knowing a
    thing, but always be ashamed of not
    wanting to know."
     
    Alastair Grant, Mar 2, 2005
    #2
    1. Advertisements

  3. Alastair Grant

    natex Guest


    Hi Alastair,

    Is Photoshop using Proof Colors? ( under "View" in the menu). I can
    recreate your banding by creating a new RGB file, painting a
    gradient, then changing the Proof Setup to CMYK and pressing CTRL+Y
    to use this setting.

    nate
     
    natex, Mar 2, 2005
    #3
  4. This isn't enabled, although I've just tried several combinations and it
    does make a difference to the style of banding - but does not disable it.

    Thanks,
     
    Alastair Grant, Mar 2, 2005
    #4
  5. Alastair Grant

    Stowey

    Joined:
    Aug 1, 2008
    Messages:
    1
    Likes Received:
    0
    Similar Display Issue

    Hi, I have been trying to figure out a solution to a similar problem that I have been having in Photoshop. My images were all appearing with banding or a sort of gradient, where there should be none. Yet all my other programs and the web seemed to display fine. This lead me to believe that it was a problem with the images or a setting in Photoshop. I am on a Mac G5 and running Tiger, and CS3. I was able to fix my issue, with a very simple solution (it is always something simple it seems). I don't know if this will help with your problem, but for me a setting had been changed in my System Preferences under Display. I went into the Display option and changed my Color setting from Thousands to Millions and now all images appear fine. I believe that I couldn't see it in other programs because the images were not displaying at a high enough resolution in those for it to be noticeable. I am not sure exactly where to find this option on a PC, but I would assume that it is a button or option under the System Display section.

    Hope this Helps, Good Luck.
     
    Stowey, Aug 1, 2008
    #5
  6. Alastair Grant

    shadowfax

    Joined:
    Nov 7, 2009
    Messages:
    1
    Likes Received:
    0
    Solution to gradient banding

    After lot of tweaking it became obvious that the problem is in the drawing algorithm of photoshop... as gradients dont show in fireworks.

    I tweaked colourspace/ 8bit> 16 bit> 32 bit without any benefit

    Also tweaked Proof setup (View> proof setup)

    It is not windows colour related as windows is 32 bit colour depth

    It is not Grafix card related as black to white gradients are displayed OK in fireworks

    Ultimately I switched off Edit > preferences > performance >GPU settings > advance settings > Advance drawing (un-check it) AND I WAS HAVING FABOULOUS SMOOTH GRADIENTS


    hOPE THIS HELPS ALL GIYS OUT THERE

    Just to give the particulars ....I am on Photoshop cs4 , windows 7 X64, Nvidia 275 gt, i7 920.
     
    Last edited: Nov 7, 2009
    shadowfax, Nov 7, 2009
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.