HELP: Canon Rebel -- overexposed (blank) shots

Discussion in 'Canon' started by vms, May 28, 2005.

  1. vms

    vms Guest

    Hi folks,

    I own a Canon Rebel body which I have used for a long while. Recently,
    it has started 'shooting blanks.' I tried several different films. But
    when they are developed they are just blank. To see if there's something
    with the shutter, I tried clicking the camera several times without film
    and lens on. It clicks ok. The mirror (of the SLR mechanism) also seems
    to operate fine. The sound of the click and shutter does "sounds" fine,
    too. That is, it does not sound like something is getting stuck somewhere.

    Any ideas?

    Thanks.
    \vms
     
    vms, May 28, 2005
    #1
    1. Advertisements

  2. vms

    Ric Trexell Guest

    To see if there's something
    *****************************************************************
    Maybe the film is not moving and you are taking several exposures on the
    same piece of film. Put a cheap roll of film in and see if it is moving
    every time. (Leave the door open.) Put a little tension of the film too
    when you do this. Sounds like it is time for a check up by a repair shop.
    RJT.
     
    Ric Trexell, May 29, 2005
    #2
    1. Advertisements

  3. vms

    Colin D Guest

    If it is *negative* film that shows blank frames, then the film is
    receiving no light, e.g. the shutter is not opening intermittently, or
    both blinds are moving together leaving no gap for exposure.

    If the shutter is staying open, then you would have no view through the
    viewfinder until the shutter closes and the mirror drops.

    Colin.
     
    Colin D, May 29, 2005
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.