help my bulb setting is stuck

Discussion in '35mm Cameras' started by meboo, Nov 7, 2006.

  1. meboo

    meboo Guest

    I don't know how i even set it on bulb. it was on manual and fine, now
    it will go to 30 on shutter speed and no further, any higher and it
    says bulb. I have tried just about everything. in programmed aperture
    setting it works fine, but in manual it won't change. I have tried the
    out button to set it back to factory settings. it is a nikon f70, i
    sure appreciate any help.
     
    meboo, Nov 7, 2006
    #1
    1. Advertisements

  2. meboo

    Draco Guest

    "...30 on shutter speed..." Is that 30 seconds or
    1/30th of a second? If it is seconds then bulb
    is the only next step in a slower shutter speed.
    Set the camera on manual setting and rotate
    the wheel near the shutter release. This should
    return the higher shutter speeds. If it shows "bulb"
    then turn the wheel in the other direction.
    The manual setting is where you, the photographer,
    choses the speed and aperture for the image you
    want to capture. Just like in the days when there
    was no program to do it for you. If you have the
    manual, check out the controls section and read it.


    Good luck,

    Draco


    Getting even isn't good enough.
     
    Draco, Nov 8, 2006
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.