Hidden tools - don't stay hidden

Discussion in 'Photoshop' started by Si, Dec 1, 2003.

  1. Si

    Si Guest

    I've a problem with PS7 (and to a lesser degree 5).

    When clicking on a new tool to select it, PS7 acts as though I've kept my
    finger on the mouse button and displays the hidden tools that correspond to
    the particular tool that I have selected. Clicking on the required tool then
    makes the hidden tools disappear.

    With 5, the hidden tools flash up very quickly, then disappear, leaving the
    correct tool selected.

    I thought it was a mouse problem as I've just installed a MS wireless mouse
    with Intellimouse 5 s/ware. But returning to my previous setup still left
    the problem.

    I'm running XP Home on an Athlon 2400+ system with 768MB ram (recently
    upgraded from 256).

    Any help?

    Si.
     
    Si, Dec 1, 2003
    #1
    1. Advertisements

  2. Si

    broga Guest

    I'd still say it was a mouse problem - reverting to a previous setup
    probably won't undo changes to the basic mouse settings which your new mouse
    software probably altered.
    At a guess I'd say it was something like speed of click or single click
    instead of double to choose. Play about with the mouse settings in Control
    panel and see what happens.
     
    broga, Dec 1, 2003
    #2
    1. Advertisements

  3. Si

    Si Guest

    Rolled back to previous driver and it still happens, there's no option to
    adjust single click in the control panel...

    Oddly it doesn't occur in ImageReady...

    Si.
     
    Si, Dec 1, 2003
    #3
  4. I'd still say it was a mouse problem - reverting to a previous setup
    I think this is just a "feature" of PS7. Are you sure that PS7 didn't behave this way before? I don't have the older versions at
    hand to test, but I think this was a change made in either PS6 or PS7. I'm not sure if I like it or not, but you can click anywhere
    outside the menu of hidden tools to select the default one. You don't have to click the menu. I generally just use the keyboard
    shorcuts and hold Shift along with them to cycle between the grouped tools.
     
    Darrel Hoffman, Dec 1, 2003
    #4
  5. Si

    Si Guest

    behave this way before? I don't have the older versions at
    I'm not sure if I like it or

    By which you mean that you seem to find PS7 operates in this fashion for you
    too?

    Simon.
     
    Si, Dec 1, 2003
    #5
  6. Si

    broga Guest

    It's not the driver it's the settings Are you sure you haven't got
    something called clicklock turned on ???
     
    broga, Dec 2, 2003
    #6
  7. Si

    broga Guest

    Done a bit of experimenting.
    If I wind up the doubleclick speed in the mouse control in Control Panel to
    almost a maximum mine does exactly the same thing.
    As you say it does it in Photoshop but not in Imageready
     
    broga, Dec 2, 2003
    #7
  8. Si

    Si Guest

    Exactly that...and as you say, the faster the double click speed set, the
    more likely it is to happen.

    Thanks for helping me to a conclusion.

    What mouse are you using - Microsoft Wireless Optical Mouse 2.0 here.

    What driver - 5.0.174.0 here.

    Si.
     
    Si, Dec 2, 2003
    #8
  9. I think this is just a "feature" of PS7. Are you sure that PS7 didn't
    Yeah, it does. I'm not using any special drivers on this machine, though. Just an ordinary Microsoft 2-button wheel mouse, not
    even optical. (I've got a 5-button optical at home, but I didn't check it there.) Checking my Double-click speed - It's about at
    3/4, on the fast side of the scale. Tried playing around with the speed here, and apparently the way it works is that if you leave
    the mouse button held down for the length of the double-click time, it will pop up the menu. Even at the fastest setting, I can
    still get it not to happen sometimes by VERY quickly hitting the button, using a quick, hammer-like attack on it. Obviously this is
    somewhat impractical. I think the fault here is with Photoshop, not Microsoft. They should be checking against the Tooltip Delay
    or Menu Delay times for this, not the Double-Click time. Oh well, what can you do?
     
    Darrel Hoffman, Dec 2, 2003
    #9
  10. Si

    Si Guest

    Just an ordinary Microsoft 2-button wheel mouse, not
    there.) Checking my Double-click speed - It's about at
    here, and apparently the way it works is that if you leave
    will pop up the menu. Even at the fastest setting, I can
    using a quick, hammer-like attack on it. Obviously this is
    Microsoft. They should be checking against the Tooltip Delay
    Just as I have, turned down the double click speed. The MS Optical Mouse 2.0
    is known for its accidental double clicks, that's why I had it set so
    fast...

    Si.
     
    Si, Dec 2, 2003
    #10
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.