just strike another problem with Vegas Pro 10

Discussion in 'Amateur Video Production' started by Brian, Feb 5, 2012.

  1. Brian

    Brian Guest

    I'm creating a short video with actors in front of s green screen. It was
    originally recorded in PAL 720 x 576.
    I have set up the session in Vegas as a Standard PAL DV project with a
    pixel ratio of 1.0926 so that there are no thin black bars at the top and
    bottom of the screen.

    When I try to compile the file as an wmv file I find that I can only set
    the pixel ratio to 1.0 square and not 1.0926, this results in the actors
    bodies not going completely down to the bottom of the screen and part of
    the background appearing at the top and bottom of the screen in thin bars
    (the background replaces the green screen).
    I tried setting the project to a pixel ratio of 1.0 but with no luck as the
    same problem appears.
    I wish Vegas had allowed the user to set the pixel ratio to what ever ratio
    the user wanted when using the wmv video format rather than just having two
    choices from a drop down menu.

    There is no problem when compiling the video in another format such as mpg2
    so the only way is to convert the video to wmv using a file converter
    program after I have compiled it in mpg2 format. I like using wmv when
    uploading a video to YouTube.

    There is also no way to compile the video to the popular Xvid and VidX
    formats but as Vegas is designed for professionals maybe most professionals
    don't need to use this video format.
     
    Brian, Feb 5, 2012
    #1
    1. Advertisements

  2. Brian

    ushere Guest

    i've never changed pixel ratio in any format, simply matched project to
    media and haven't encountered any problems since vers 4.
    xvid, et al are ok distribution formats, but useless for editing. i
    don't know of any nle that exports to that format?
     
    ushere, Feb 5, 2012
    #2
    1. Advertisements

  3. Brian

    Mxsmanic Guest

    Depending on pixel ratios other than unity may haunt you throughout
    post-production, even if you get this to work. Just leave the black bars.
     
    Mxsmanic, Feb 5, 2012
    #3
  4. Brian

    Brian Guest

    I can't leave the black bars as they get replaced with part of the
    background picture when i compile the video. If i was able to set the pixel
    ratio to 1.0926 before compiling the video in the wmv format then there
    would be no problem. its liked putting a slightly smaller picture over a
    larger picture.
    The wmv format must be sensitive about the pixel ratio setting as when I
    compile the video using mpg2 then I don't need to set the pixel size and
    the video has no problems after being compiled.
     
    Brian, Feb 5, 2012
    #4
  5. Brian

    Brian Guest

    When I selected the PAL DV format 576 x 720 then Vegas automatically chose
    this pixel ratio (1.0926). Normally there would be no problem but in this
    case I'm replacing the green screen with a background picture.
    Like I said in an earlier post sometime you need to have certain conditions
    to reveal a problem in software.
     
    Brian, Feb 5, 2012
    #5
  6. Brian

    mike Guest


    Render it as a DV-AVI file first (the quality loss will be
    imperceptible) and use that render to make your WMV file.
    You can render to Divx or Xvid (they will be AVI variants) as long as
    you have the codecs installed.
    Make sure to get them from a reputable site.

    Mike
     
    mike, Feb 5, 2012
    #6
  7. The wmv format must be sensitive about the pixel ratio setting as when I
    A good inference. Test your theory rendering to an MPG2, and then
    convert the MPG2 into a WMV with a different program. This will tell
    you if the problem is with WMV format in general, or just the program
    you're currently using.

    .... experimentation, a good way to embody "what if" questions.
     
    ReverendFuzzy, Feb 5, 2012
    #7
  8. Brian

    Mxsmanic Guest

    Most still photos have square pixels. Maybe the discrepancy is confusing
    Vegas.

    You could try cropping the image to exclude the black bars, or rendering the
    material with the unusual pixel ratio to a format with square pixels, and then
    using that to matte in your background on a second pass.
     
    Mxsmanic, Feb 5, 2012
    #8
  9. Brian

    Brian Guest

    Thanks Mxsmanic for your suggestions.
    Also I think there is a way of zooming into the output of the picture in
    Vegas so the black bar are not present in the compiled video but need to do
    some exploring to find out how.
     
    Brian, Feb 6, 2012
    #9
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.