Kodak Carousel 760H Slide Projector

Discussion in 'Kodak' started by Jo, Dec 6, 2003.

  1. Jo

    Jo Guest

    last time I used my slide projector all was right with the world --
    now when I power it up -- the fan will not turn over -- however the
    light does comes on -- took it apart to make sure that there was
    nothing stuck in the fan but all seems right with it and there does
    not appear to be any dust clogging anything -- the instruction manual
    references a thermal fuse in cases where the exhaust fan or motor fail
    -- anyone have to have this type of repair and is it costly to makee
    such repair -- thanks for reading and your thoughts in this matter --

    please write with responses to
     
    Jo, Dec 6, 2003
    #1
    1. Advertisements

  2. Does the fan turn freely when you spin it by hand. My first thought is that
    the lubrication in the fan is old and just turned to stickiness instead of
    slickiness. See if you can spin it freely by hand; give it a shot of WD-40
    in all cases and see if that does the trick.
    Sorry, I only post; I never email.
     
    Phil Stripling, Dec 6, 2003
    #2
    1. Advertisements

  3. How are you at using a test meter? If you can, track down the current
    to the motor. It may be a switch, or a bad wire or if the motor is getting
    current, then you are down to the motor.

    I don't think it has a fuse, just for the motor. I believe the over
    heat safety shuts off the lamp as well (at least it does on the pro line).
     
    Joseph Meehan, Dec 6, 2003
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.