LCD Flicker. And windows won't keep changes to the display settings!

Discussion in 'Amateur Video Production' started by photoguy_222, Mar 15, 2007.

  1. photoguy_222

    photoguy_222 Guest

    Dear experts,

    I've seen some really strange behavior lately, like I've
    never seen before.

    I have a Dell 4600, with an Nvidia Geforce 5200 card in it.
    To date, I've used a simple CRT monitor from Dell.
    But this week, I bought an LCD screen from Sony.

    There was some flicker. So, I downloaded the latest
    drivers and everything from NVidia, and installed
    everything. There still was flicker. So, I
    decided to compare.

    I also have a Sony laptop, and an LCD TV. I use
    my Laptop to play DVDs on the TV. I took the 4600
    downstairs, and plugged it into the TV. It had
    weird display setting when I logged in, but I
    changed them and it worked fine. No flicker on
    the TV.

    I also brought the LCD display downstairs, and
    tried it with the same 4600 computer there.
    Interestingly enough, no flicker.

    So, what is causing the flicker with the LCD?

    I also have another desktop, with an ATI card, that
    sits right beside the 4600, and it doesn't give flicker
    with the LCD. (I use a KVM switch to move between computers.)

    So, the location makes a difference.
    Upstair flicker
    downstairs no flicker

    But, why would I also not get flicker with the other
    machine, right beside it? Strange!

    The machines are XP/Linux dual boot. On the 4600,
    it also flickers in Linux.

    I read that perhaps the power source might have something to
    do with it. So, I ran an extension from the main floor
    upstairs. No difference.

    So, if that is not enough, today when I boot the 4600,
    the video settings are off. They are the same as they
    were with the LCD TV. I change them back. And when I
    reboot, they go back to what they were with the LCD TV!

    What a bother!


    How do I set the video settings so that they stay as I
    set them? when I reboot, they are the same as what I
    set them to.

    Any ideas on what is causing the flicker?
    photoguy_222, Mar 15, 2007
    1. Advertisements

  2. photoguy_222

    nappy Guest

    What refresh freq did you set the GeForce card up to?
    nappy, Mar 15, 2007
    1. Advertisements

  3. Check the refresh rate in Display Settings of Control Panel. It is more
    than likely set to 75 or so. Change it to 60 to stop the flicker.
    Completely Lost, Mar 15, 2007
  4. With the ATI drivers the settings you'll see without forcing the issue will
    depend on the .INF file for the monitor. So the next question is, are the
    settings ones that the monitor supports? Whether or not the GeForce works
    this way it's best to have the proper .INF file. If the monitor didn't come
    with one get it from MFG website. If Windows doesn't detect the monitor
    change check Device Manager to see what the display is set for. Install the
    correct .INF.

    Display issues are almost always driver issues. It certainly isn't necessary
    to cross post something so simple to 4 groups. Start with the video card
    group. Not that familiar with Nvidia but seriously doubt it's worth
    repairing anyway. Would make much more sense to get a newer card if it had a
    hardware problem.
    Captain Midnight, Mar 15, 2007
  5. Check the KVM and all of the cables, in addition to the other
    suggestions given.
    Gene E. Bloch, Mar 15, 2007
  6. photoguy_222

    Yousuf Khan Guest

    Depends, are you using the VGA cable to connect to the LCD or a DVI
    cable? VGA cables are analog, while DVI are digital. This normally
    wouldn't make a difference to an LCD monitor, except unless if the LCD
    has a crappy analog-to-digital converter built-in, then you might see
    artifacts like this when connecting through a VGA cable. There won't be
    any such problem if you connect with a DVI cable, since it's all digital
    all of the way.

    Yousuf Khan
    Yousuf Khan, Mar 16, 2007
  7. photoguy_222

    photoguy_222 Guest

    Change the refresh rate to 60 hz to stop the flicker.

    That was the solution!
    Geez, you are good!

    Thanks a lot!!!
    photoguy_222, Mar 16, 2007
  8. photoguy_222

    Bill's News Guest

    I replaced my very old KVM with a new one just a few days ago.
    My old MAG 17" LCD display is the one which I switch. It's a 75
    Hz unit and for some reason when I switched it to the newer PC
    its driver kept getting reset to 60 Hz, which causes a dazzling
    effect rather than flicker.

    The two PCs use the same ATI x1300 256 PCIe card. After
    resetting the scan rate to 75 in CCC for at least the fourth
    time, it finally took and the display has been fine since.
    Bill's News, Mar 22, 2007
  9. photoguy_222

    PeterD Guest

    The KVM is not properly switching the monitor ID lines, only the video
    lines. I think there is a way to specify that the driver ignore the
    Monitor ID and just use what you specify...
    PeterD, Mar 22, 2007
  10. photoguy_222

    Bill's News Guest

    You may be right, but there is no driver with this KVM. There
    is an app to allow click switching, as the chosen "scroll lock"
    hot key is a problem on both of my wireless keyboards which
    double up that function on a key. I don't use the app, I've
    chosen to place the KVM controller box on the floor and tap the
    large, top-mounted action button with my right foot.

    The USB keyboard is also seen by each OS as coming and going,
    and that really should not happen either. I'm going dingy from
    all the dings;-)
    Bill's News, Mar 23, 2007
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.