Memory card won't format : Sony dsc-w50

Discussion in 'Digital Cameras' started by Howard, Dec 21, 2010.

  1. Howard

    Howard Guest

    Hi all,

    I have a Sony dsc-w50. It's great for taking every day photos and it
    works fine.

    However it is very slow to start up. I solved this same problem, as I
    recall, a couple of years ago by reformatting the memory card.

    But now when I try to do that it comes up with a "Formatt Error"

    It doesn't stop it working grand other than the delay on startup.

    Any ideas anyone ?

    Howard
     
    Howard, Dec 21, 2010
    #1
    1. Advertisements

  2. Are you formatting in the camera or in your computer?

    David
     
    David J Taylor, Dec 22, 2010
    #2
    1. Advertisements

  3. Howard

    Howard Guest

    In the Camera - there is a formatting option.

    Others are saying this is a faulty memory ? yet it works fine in
    allmother respects ... I am confused :-(

    Howard
     
    Howard, Dec 22, 2010
    #3
  4. In-camera is the best way to format, Howard. If you have used a Mac, it
    may have written other files to the card preventing its use in the camera
    (that can happen with cards for the Garmin GPS). Now you must ask: what
    is the price of a new card compared to the effort to resolve issues with
    this one?

    Cheers,
    David
     
    David J Taylor, Dec 23, 2010
    #4
  5. Howard

    Howard Guest

    I agree. Funds are 'incredibly' tight right now though :(

    H
     
    Howard, Dec 23, 2010
    #5
  6. You aren't the alone in that. Perhaps someone can send you a spare card
    or perhaps someone may buy you a Christmas gift. I see that it's a Sony
    Memory Stick.

    Cheers,
    David
     
    David J Taylor, Dec 24, 2010
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.