nikon D70 fault?

Discussion in 'Nikon' started by laz, Aug 25, 2004.

  1. laz

    laz Guest

    can anyone tell me if you have encountered any faults with the D70,,,
    I am noticing faded lines to the top of the picture i was wondering i this
    is normal.
     
    laz, Aug 25, 2004
    #1
    1. Advertisements

  2. I had a problem with the flash and then one with intermittent
    focusing, but mine was one of the very first on the market. No
    problems since.
    Roger Halstead (K8RI & ARRL life member)
    (N833R, S# CD-2 Worlds oldest Debonair)
    www.rogerhalstead.com
     
    Roger Halstead, Aug 25, 2004
    #2
    1. Advertisements

  3. laz

    MikeS Guest

    I had a tilted image after Nion had tried twice to fix it I gat a
    replacement.
    MikeS
     
    MikeS, Aug 25, 2004
    #3
  4. After I had a Tokina ATX-400mm f/5.6 mounted, my D70 would not allways
    accept my other lenses (mainly Nikkors). The D70 could not find them -
    it acted like no lens was mounted!

    I returned it for repair and (eventually) got a replacement.

    Peter
     
    Peter Rongsted, Aug 25, 2004
    #4
  5. laz

    Ray Paseur Guest

    I have not experienced any trouble, but there were some early rumors of
    "back focus". A test is available here:
    http://md.co.za/d70/

    There are a very few annoyances, like not being able to easily see the ISO
    setting, but these are not really faults, just matters of design. It's a
    great camera.
    ~Ray
     
    Ray Paseur, Aug 25, 2004
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.