Olympus 5060 Faulty On Off Switch?

Discussion in 'Olympus' started by Ken, Feb 6, 2005.

  1. Ken

    Ken Guest

    Just bought an Olympus 5060 yesterday and already beginning to feel there is
    a fault.

    Sometimes the on/off switch appears to not quite be working. When camera
    switched on it will just turn itself off but if I push the on/off switch a
    bit more it comes on but often goes off again when I let go.

    Also I have had menu option suddenly appear on the screen when no button is
    pressed.

    Is it me or is this a known problem?

    Ken
     
    Ken, Feb 6, 2005
    #1
    1. Advertisements

  2. Ken

    Ken Guest

    Thnaks Alfred

    I have just been googling and realise I am one of the unlucky ones.

    I am enjoying learning how to use the camera and assume it is worth getting
    a repair?

    Ken
     
    Ken, Feb 6, 2005
    #2
    1. Advertisements

  3. Alfred Molon wrote:
    []
    The Nikon 990 suffered from mode dial problems, although you could effect
    a repair simply by putting a drop or two of electronic switch-cleaner near
    the gap of the rotating part of the dial, and then rotating the switch to
    work the switch-cleaner in.

    Might that also work for the 5060?

    Cheers,
    David
     
    David J Taylor, Feb 6, 2005
    #3
  4. Any comments. Alfred?

    David
     
    David J Taylor, Feb 6, 2005
    #4
  5. Alfred Molon wrote:
    []
    Ah, I didn't appreciate that.

    Thanks,
    David
     
    David J Taylor, Feb 6, 2005
    #5
  6. Ken

    Ron Guest

    I had a mode dial switch problem with my 2020 and fixed with a couple of
    drops of switch-cleaner. Dunno about the 5060, but from what I've heard
    it might really require factory service, being a true hardware problem.

     
    Ron, Feb 14, 2005
    #6
  7. Ken

    Ken Guest

    The camera went back to the supplier and they shipped - same day they
    received - a new one and so far all OK.

    It seems it is a good camera.

    Ken
     
    Ken, Feb 15, 2005
    #7
  8. Anyone knows if we can expect the problem solved in the new C-7070 WZ.. or
    should I go for the 8080?

    (I was originaly gonna go for the 5060, as that is already above the level
    I need)
     
    Dalibor Bauernfrajnd, Feb 15, 2005
    #8
  9. There's no additional warranty avaliable here where I live, and the 5060
    is around $700; it was $800. The C8080 is $1k. See the problem?

    Buyin' from abroad is out, warranty issues.

    Fixing the mode-dial problem without warranty costs almost as much as the
    digicam itself here.

    So, whatever I get, it has to work!

    (please leave a part of the text you're replying too, I almost missed this
    post).
     
    Dalibor Bauernfrajnd, Feb 15, 2005
    #9
  10. Yeah, exactly.
    Yeah, I'm gonna consider both of those, but at that price, I can get the Oly
    8080. And here we go again! :)
     
    Dalibor Bauernfrajnd, Feb 17, 2005
    #10
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.