Pentax P30 (P3) Question

Discussion in 'Pentax' started by Russell, Jul 19, 2004.

  1. Russell

    Russell Guest

    I have an old Pentax P30 (P3) which I occasionally use as a backup
    body. The other day I noticed 2 things. Firstly that the battery had
    gone flat and secondly that the film winder would not wind. Are these
    related, or is there something wrong with my camera? Since it is a
    manual camera, I assume that the winder problem and the flat battery
    are not related, but I would like to remain hopeful.. Does someone
    here who has this body know if a flat battery prevents the winder from
    functioning?

    Failing this I guess I could just go and buy a battery and check for
    myself :)

    Thanks in advance
    Russell.
     
    Russell, Jul 19, 2004
    #1
    1. Advertisements

  2. Russell

    Chris B Guest

    Well... you need a battery to make the shutter fire, don't you? The P30
    doesn't have a mechanical shutter speed AFAIK so if your battery has gone
    flat and you've wound it on once, you're not going to be able to wind it
    again!!

    Chris.
     
    Chris B, Jul 19, 2004
    #2
    1. Advertisements

  3. Russell

    Russell Guest

    Good point! (and good news!). Thanks for the reply :)

    Cheers,
    Russell
     
    Russell, Jul 19, 2004
    #3
  4. No, it will do fixed-program automation with KA lenses. Pretty lame,
    though; it seems biased to quick shutter speeds at the expense of
    depth-of-field.

    <snip>
     
    Stephen H. Westin, Jul 19, 2004
    #4
  5. Russell

    Russell Guest

    For the record, replacing the batteries worked and my old workhorse is
    back in business!!

    Thanks to all for the replies :)

    Cheers,Russell.
     
    Russell, Jul 19, 2004
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.