Pentax SuperProgram/ Super-A help?

Discussion in 'Photography Equipment' started by castellscouple, Dec 6, 2011.

  1. castellscouple

    castellscouple

    Joined:
    Dec 6, 2011
    Messages:
    1
    Likes Received:
    0
    Location:
    Ohio, USA
    I have scoured the dregs of photography forums to find many people having similar issues as I'm having with my oldie but goodie Pentax SuperProgram (AKA the Super-A).
    My problems lies is the wide variety of answers and solutions presented; I'm just not sure what to do as none of the answers I've read seem to work...
    I know how to load the film properly. I've advanced the roll past 0 so as to ensure the AUTO exposure reads correctly (not the 1/1000 preloaded default).
    I've got a new battery and the only issue (although highly important) is that the Shutter release button simply will not take a photo.
    The button can be fully pressed but no sound occurs and the film advance lever can be ratcheted as much film as the operator desires
    (I've exposed a good amount of film trying to solve this issue.)

    Please let me know if you can help at all. I've tried every order of operation I could think of with little to no avail. help?:confused:
     
    castellscouple, Dec 6, 2011
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.