Playing mpg on PC.

Discussion in 'Video Cameras' started by Grumps, Feb 16, 2007.

  1. Grumps

    Grumps Guest

    Windows XP SP2. A recent update to Media Player, and it's now version 11
    (even though it said it was updating version 10).
    Anyway, everytime I try to play an mpg I get a moving banner at the bottom
    of the media player screen saying "Evaluation period expired for Elecard
    MPEG decoder" or other such phrase. I have absolutely no idea what this is.
    I have never installed such a decoder. And the question is, how do I remove
    it?
     
    Grumps, Feb 16, 2007
    #1
    1. Advertisements

  2. Grumps

    Rob Guest

    XP doesn't come with an MPEG2 codec which is required to
    play mpeg2 files, so you have to install one yourself (ie mpeg2
    codecs are licensed.) The easiest way to get a licensed codec
    is to install DVD player software, such as PowerDVD.
    The Elecard trial codec you currently have installed would have
    come with some other software you have installed, such as codec
    packs, video format conversion software, etc. Alternatively you
    could contact Elecard directly and pay the licence fee.
    HTH,
     
    Rob, Feb 16, 2007
    #2
    1. Advertisements

  3. Grumps

    Grumps Guest

    Thanks.
    My PC came with PowerDVD, so that should've included a licensed MPEG
    decoder.
    So now all I need to do is;
    1) Get rid of Elecard (it's not in start>programs or add/remove programs),
    or maybe
    2) Re-install PowerDVD (and hopefully that will change my PC's settings to
    use its decoder.
     
    Grumps, Feb 16, 2007
    #3
  4. Grumps

    Jukka Aho Guest

    I had a similar problem a while ago. Installing a demo version of their
    MPEG-2 Player (which comes with that codec) and uninstalling it
    immediately afterwards helped:

    <http://www.elecard.com/download/>
     
    Jukka Aho, Feb 16, 2007
    #4
  5. Grumps

    Grumps Guest

    Thanks.
    I just tried that, I was quite hopeful that it'd work, but it didn't :-(
    So I uninstalled and re-installed PowerDVD and made that the default mpg
    player. This seems to work so far.
     
    Grumps, Feb 16, 2007
    #5
  6. Grumps

    Jukka Aho Guest

    This might have worked, too:

    <http://www.elecard.com/support/kb/answer.php?faq_id=20>
     
    Jukka Aho, Feb 16, 2007
    #6
  7. Grumps

    Grumps Guest

    Thanks for the pointer.
    Yes, that looks like it should work. However, I don't have a
    programfiles\commonfiles\elecard directory.
    I wonder what app installed this in the 1st place.
     
    Grumps, Feb 16, 2007
    #7
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.