Possible fix for Canon Canocraft software - Other error

Discussion in 'Canon' started by Jason Freake, Aug 30, 2003.

  1. Jason Freake

    Jason Freake Guest

    I just wanted to outline a possible fix for Canon scanners
    giving the "Other error" on program startup. I searched the
    net and this solution does not seem to be a common one.

    ---This may not work for everyone but it worked for me.---

    I am using a Canon N340p parallel flatbed scanner.
    When I started the Canon software "Canocraft" it would display "Other error"
    and it would prevent me from scanning.

    The cause, in my situation, was I have my parallel port set in my BIOS to
    bidirectional (which was working ok but it was slow for my printer) and
    when
    I changed it to ECP, the scanner stopped working.

    I did a re-install of the Canon software which did not work.
    When I was rooting around in the registry I changed a key that has solved my
    problem.

    -------NOTE TO NOVICE USERS------------------------------
    -------Backup your registry before making changes to it.----------

    1. go to [HKEY_LOCAL_MACHINE\SOFTWARE\Canon\CanoScan FBP3\SCFBPPM3]

    2. change the value of IFMODE to "2" (without the quotes)

    Now when I start Canocraft...it says my scanner is in ECP S mode and it
    works. :)
     
    Jason Freake, Aug 30, 2003
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.