Problem with light meter in Nikon FM2

Discussion in 'Nikon' started by Chuck, Dec 31, 2003.

  1. Chuck

    Chuck Guest

    I have an FM2 that is in excellent condition, with one exception. This
    camera has been in storage for about 15 years (without batteries) and
    I just took it out to use it. Everything works fine, except the light
    meter LEDs won't show. I tried 2 different sets of new batteries, no
    luck. I know the meter worked the day I put the camera away. It is as
    if the electronics "aged" just sitting there and no longer work. Does
    this make sense? Is there some trick I forgot to turning on the meter?
    (I know I have to move the film winder a bit.)

    Thanks in advance,
    Chuck Connell
    781-939-0505
    www.chc-3.com
     
    Chuck, Dec 31, 2003
    #1
    1. Advertisements

  2. Chuck

    Mike Guest

    Did you press the release?
     
    Mike, Dec 31, 2003
    #2
    1. Advertisements

  3. Chuck

    Pete Guest


    Did you wind on to frame 1? Maybe it won't work while the counter is on the
    leader frames; some other Nikons do this. Then, press the shutter release
    halfway. -Pete
     
    Pete, Dec 31, 2003
    #3
  4. Chuck

    Phil Cole Guest

    Don't know about the FM2, but the FE2 won't turn the light meter on
    until the film counter has advanced to position 1 (so you have to trip
    the shutter and wind on about 3 times after you load film/close the
    back). could be the same for the FM2 ....

    Hope that helps,

    Phil
     
    Phil Cole, Jan 7, 2004
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.