Problems installing Canon G3 driver/software

Discussion in 'Canon' started by VG, Jan 9, 2005.

  1. VG

    VG Guest

    I am using Windows2000 and I recently purchased a Canon G6 digital camera.

    I loaded the software which appeared to install correctly. Rebooted the
    computer and then connected the
    camera. This should then have completed the installation of the Twain
    driver, but it failed before completion with the words 'Upgrading Device
    Driver wizard. An Error Occurred during the Installation. Access Denied'.
    I have an older Canon G3 camera driver & software installed on the same
    machine, but obviously
    don't have it connected when I try to install the G6

    I am the sole user of this machine; I do not use a password, and the
    question of administrative privilages does not arise. At least I don't think
    so, as I have never had problems of this kind when instsllling software in
    the past!

    When I connect the G3 to my PC (after the failed installation of the G6),
    the usual window opens presenting me with a list of programs which I can use
    with the G3, but it no longer shows the Zoom Browser - which has now been
    upgraded by the G6 installation to a newer version.
    The only way I can now download pictures from my G3 is via the Canon File
    Viewer Utility.

    The problem I now have, is that I am still unable to load the twain driver
    for the G6, and the software that previously worked ok on the G6, does not
    function correctly (since upgrading) on the G3.

    I have tried uninstalling the driver and software for the old G3 before
    installing the G6, but I still have the same problem.
    I have also tried installing the new version of the Zoom Browser, on it's
    own - without any of the other G6 software or it's driver, but the G3 still
    does not have access to the Zoom Browser.

    I took the camera and software disc to the shop where it was purchased, and
    it installed and worked fine on their Windows XP machine, so I obviously
    have a conflict somewhere on my Win2k machine.

    I suspect there is an item somewhere in the Registry or 'C' Drive lingering
    from a previous installation; I would like to know what to look for.

    I have been in touch with Canon, and they have suggested the obvious, such
    as disabling the antivirus and firewall - which I have done, but nothing
    really constructive has come out of our discussions. My local dealer
    suggested I re-install Win2k. That on it's own would be no real problem, but
    loading all my other software and updates would take a week or more.

    I don't expect anyone on this NG come up with a magic solution for my
    particular PC, but perhaps someone has had roughly similar problems, and I
    would be interested to hear how they resolved them.

    Thanks in advance for any suggestions.

    V.G.





    ..



    I have tried just about every sequence of software installation to overcome
    this problem, but without success so far. Getting desperate!
     
    VG, Jan 9, 2005
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.