Puzzle of Camstudio AVI

Discussion in 'Amateur Video Production' started by Terry Pinnell, Dec 6, 2007.

  1. Occasionally I fire up CamStudio to make a short movie of my screen
    actions, to illustrate something in a newsgroup or forum. Camstudio
    records it all OK, and plays back video and audio correctly directly
    afterwards. But I always hit problems in the subsequent stages of
    preparing my movie if I forget that there's only one of my editors
    that processes it OK.

    I'd really like to get to the bottom of it with help here please. Also
    posted in http://forum.videohelp.com/topic341700.html#1783323

    I've always been in a hurry to get the task finished, so this time
    I'll step through a small example methodically and show all the
    details.

    This capture was in a typical application (Memory-Map) and is only 7
    secs duration. The file is CamStudioTest1.avi, at:
    http://www.speedyshare.com/714779974.html

    Even so, it's still over 9 MB in size. (The typical movie I tried to
    make earlier this morning was 2:40, 138 MB, which of course is why I
    cannot simply upload it as it stands.)

    It plays fine in all the players I tried.
    VirtualDub reports the following:
    Video stream
    Frame size, fps (us per frame) 1024x768, 25.000 fps (40000 uS)
    Length: 181 frames (0:07.24)
    Decompressor: CamStudio Lossless Codec v1.0 (CSCD
    Number of key frames: 7
    Min/avg/max/total key frame size: 1109913/1110148/1110234 (7589K)
    Min/avg/max/total delta frame size: 0/4939/13643 (840K)
    Data rate: 9537 kbps (0.05% overhead)

    Audio stream
    Sampling rate: 44100Hz
    Channels: 2 (Stereo)
    Sample precision: 16-bit
    Compression: PCM (Uncompressed)
    Layout: 91 chunks (0.08s preload)
    Length: 317961 samples (0:07.21)
    Min/avg/max/total frame size: 1764/13976/14112 (1243K)
    Data rate: 1411 kbps (0.17% overhead


    GSpot reports the following:
    --- Video Information ---
    Video Codec Type(e.g. "DIV3"): CSCD
    Video Codec Name(e.g. "DivX 3, Low-Motion"): RenderSoft CamStudio
    lossless Codec (LZO & GZIP compression)
    Video Codec Status(e.g. "Codec Is Installed"): Codec(s) are Installed
    Duration (hh:mm:ss): 0:07.240
    Frame Count: 181
    Frame Width (pixels): 1024
    Frame Height (pixels): 768
    Storage Aspect Ratio("SAR")" 1.333
    Pixel Aspect Ratio ("PAR"): 1.000
    Display Aspect Ratio ("DAR"): 1.333
    Fields Per Second:
    Frames Per Second: 25.000
    Pics Per Second: 25.000
    Video Bitrate (kbps): 9536
    Quality Factor (bits/pixel)/frame: 0.485"

    --- Audio Information ---
    MPEG Stream ID (e.g. "0xbd"):
    MPEG VOB file Substream(e.g. "0x80"):
    Audio Codec (e.g. "AC3"): PCM Audio
    Audio Codec Status (e.g. "Codec Is Installed"): No Codec Required
    Audio Sample Rate (Hz): 44100
    Audio Bitrate(kbps): 1411
    Audio Bitrate Type ("CBR" or "VBR"):
    Audio Channel Count (e.g. "2" for stereo): 2

    But here's what happened when I opened it in the following programs:

    Womble MPEG Video Editor (DVD)
    Imported OK. Played the audio OK, but no video (black monitor window).

    MAGIX MovieEdit Pro 11 e-version
    (Just started learning the very basics of this new purchase.) On
    importing the AVI, hung solid. Had to be terminated via Win XP Home
    Task Mgr.

    MemoriesOnTV Pro
    Imported OK. It played, but the video is about 3 seconds ahead of the
    audio. The rendered MPEG naturally has same flaw.

    Windows MovieMaker
    Success! Imported OK. Previewed OK. Rendered OK. (To a 490 KB WMV.)

    So: why does it give all 3 programs problems of varying severity, yet
    MovieMaker handles it fine? And how can I get those others to like it
    too?
     
    Terry Pinnell, Dec 6, 2007
    #1
    1. Advertisements

  2. Terry Pinnell

    Ken Maltby Guest

    Magix Movie Edit 12 just gives an error mesage, that
    it can't open the file.
    Read all the CamStudio "Help" there is a lot of info, tucked into
    seeming unrelated explainations. About 4/5 of the way down the
    page there is an "Audio and Video Synchronization" section.
    It also seems to work in Ulead's VideoStudio 10+. It can
    be transcoded with TMPGEnc XPress 4.0, no problem. So
    you might want to try a few encoding/converting/programs, to
    get it into a more compatible format.

    Luck;
    Ken
     
    Ken Maltby, Dec 6, 2007
    #2
    1. Advertisements

  3. Thanks Ken, I will. But I guess I'll stick to MovieMaker for this
    task, unless I can discover how to get other programs to deliver.

    I thought I'd read somewhere that video editors access whatever codecs
    you have installed on your system. Is that in fact not true? If it was
    true, then - as I plainly have the CamStudio codec installed - I don't
    see why these other programs all fail.
     
    Terry Pinnell, Dec 7, 2007
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.