RICOH RDC-7 Unusual fault

Discussion in 'Ricoh' started by Lago Jardin, Apr 19, 2004.

  1. Lago Jardin

    Lago Jardin Guest

    Hi
    I bought a Ricoh ROC-7 from Nomatica in Siege via the internet on 6/12/2001.

    I have found the camera to be excellent. However, after d/l some pictures
    when I came to use my camera again, I found that most of the controls would
    not work except the dioptor knob. The LCD monitor is fine and I can see a
    picture both old and proposed picture. The zoom, shutter, erase, settings,
    int/card, operation panel buttons will not change. However, if I use the
    remote control the camera works normally.I have also tried removing the
    SmartMedia card. I have tried following the reset instructions(remove
    battery etc) and also pressing the reset button but these do not clear the
    fault. I am from Leeds in the UK but I live in Spain. The camera has not
    been dropped or damaged in any way.

    Does anyone have any idea of the likely fault and any solution please. I
    understand that there are some camera repair manuals available. Anyone any
    info on these if relevant please.

    Thanks

    Nigel Smith
     
    Lago Jardin, Apr 19, 2004
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.