Sont PC110E background hiss on recordings

Discussion in 'Amateur Video Production' started by Toby Edwards, Jan 2, 2005.

  1. Toby Edwards

    Toby Edwards Guest

    My Sony PC110E has started to develop an unpredictable background hiss
    (varying between as best described standing near a water fall or right
    in it drowning out all sound !). Some recordings come out fine (I have
    an hour of footage taken 4 days after a previous with hiss ...).

    What I find amazing is my father has an identical model bought 3
    months prior to mine (both cameras are about 40 months old). Guess
    what ? His has just been repaired following such a fault. Apparently,
    the drum went out of allignment. Fixing it cost forking out £60 to
    "see what was wrong" THEN a further £290 to repair it ! Definately not
    within my budget ...

    I find it a little odd (annoyed now at the footage which has been
    destroyed) that the exact same model camera at the same time starts
    developing this fault !

    I'd love to know if anyone has a similar problem with a PC110E ? What
    did it cost to repair ? Can spare parts be bought from somewhere on
    the net ? Anyone know how to "align the drum" ?

    I am handy with a solering iron, I've fixed other stuff before
    (satelite box/XBOXes/PCs etc). So am willing to "dabble" !!!
     
    Toby Edwards, Jan 2, 2005
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.