sony products not picking up Dx plugins

Discussion in 'Amateur Video Production' started by dave xnet, Feb 11, 2006.

  1. dave xnet

    dave xnet Guest

    Hello all,
    seems a few have had this problem.
    In my case, Sony Vegas 5 and Sound Forge 8a are
    apparently not scanning for, nor displaying recently added
    plugins such as Waves Restoration Demo.

    There are various suggestions on the Sony site such as
    deleteing the "Dxcache" entry in the the registry at
    [HKEY_LOCAL_MACHINE\SOFTWARE\Sony Media Software\Sound Forge\8.0]

    and the same for Vegas. In my case, "dxcache" does not exist.

    A second suggestion had to do with NTFS 8.3 file name creation
    suppression.
    They suggest leaving in set to 0, but I;m not sure if this is supposed
    to be set prior to the installation of the Sony product and/or
    the plugin. Something is odd about this. I installed
    the demo of Wavelab and it picked up the new plugins as expected.

    Any ideas of how to troubleshoot further appreciated.
    Dave
     
    dave xnet, Feb 11, 2006
    #1
    1. Advertisements

  2. dave xnet

    Mike Kujbida Guest


    First of all, I don't think you're looking far enough into the registry. I
    just tried it and found all my DXCache folders for both Sound Forge & Vegas.
    Make sure you were follow the instructions below exactly.

    Using the Registry Editor interface, navigate to the following directory:
    HKEY_LOCAL_MACHINE\SOFTWARE\Sony Media Software. Within this directory you
    will see subdirectories for all Sony Media Software applications and their
    subcomponents.

    Find the folder for the application that you are working with and click the
    '+' sign next to it. You will see another set of subdirectories: DXCache,
    License, and Metrics.


    And here's a few other suggestions from the Sony Vegas forums for you to
    try.

    1) In your installation directory, C:\Program Files\Sony\Shared
    Plug-Ins\Utilities\Migration Tools, there is a tool for migrating your FX
    plugins and such. Review the readme and follow the instructions.

    2) Look in the 3rd party folder for FX to see if they're there.

    3) AnalogX DXMan at http://tinyurl.com/3fws4 is sometimes a useful tool as
    well.

    Mike
     
    Mike Kujbida, Feb 12, 2006
    #2
    1. Advertisements

  3. dave xnet

    dave xnet Guest

    Mike, thanks for the response.
    For now, I've uninstalled the sony products. I will clean the
    registry of related sony entries and reinstall tomorrow.
    (Perhaps just one product to keep it simple)

    I can assure you I searched the registry correctly using REGEDIT.

    You mention the subdirectores DXcache, metrics and licence.

    For both vegas and SF, only "metrics" and "license" were present.
    I though the sony products would recreate this key?
    I troubleshooted further by downloading sysinternals.com product
    REGMON. I monitored the startup of SF and I can clearly see
    the open for the DXcache key with the status "FAILED".
    But no further references to it.

    I'll post back tomorrow after I reinstall.
    Dave
     
    dave xnet, Feb 12, 2006
    #3
  4. dave xnet

    Mike Kujbida Guest


    Dave, I'm assuming you installed SF after Vegas. I vaguely recall reading
    on the Sony Vegas forum about this causing similar issues to yours. For
    some reason, this would mess things up and the cure was an
    uninstall/reinstall of Vegas after SF. Good luck with it.

    Mike
     
    Mike Kujbida, Feb 12, 2006
    #4
  5. dave xnet

    dave xnet Guest

    It gets stranger and stranger. I reinstalled SF by itself.
    Still no DXcache was created; DX plugins not picked up.

    I reinstalled Vegas. He created DXcache - everything OK.
    Then installed the demo of Waves Restoration, Vegas picked
    it up but not Sound forge.

    Judging from the contents of DXcache right at the beginnning
    are a series of checksums. I assume this is the way the SF products
    can tell if some components have been added, and if so rebuild its
    cache. Why it's not working at all for SF8 at this point is a
    mystery.

    Dave
     
    dave xnet, Feb 12, 2006
    #5
  6. dave xnet

    Mike Kujbida Guest


    Dave, here's another thought. You said you were running SF 8.0a. There's
    an 8.0b upgrade that lists, among other fixes "A bug has been fixed that
    could cause DirectX and VST plug-ins to remain in the FX Favorites menu
    after removing or hiding the plug-ins". Might be worth getting the update
    and see if that solvesyour problems.

    Mike
     
    Mike Kujbida, Feb 13, 2006
    #6
  7. dave xnet

    dave xnet Guest

    Mike, I had tried it earlier - no dice, but
    I have since found the real problem!
    I had installed SF to a non-standard location because my
    system partiion is quite small. Instead of
    c:\program files\sony\sound forge 8.0
    c:\program files\sony\shared plugins

    I installed it to
    i:\program files\sony\sound forge 8.0
    i:\program files\sony\shared plugins
    Which is a much larger ntfs partition on a second drive.
    Why this makes a difference I don't know - the product was
    working normally except for this.
    I've since installed 80b and Vegas - all is well.
    Perhaps I'll leave a note in the official Sony forum.
    Thanks for your help.

    Dave
     
    dave xnet, Feb 13, 2006
    #7
  8. dave xnet

    Mike Kujbida Guest


    Dave, glad you finally got it sorted out.
    Your C drive must be really small :)
    I'm sure you have your reasons for having two system drives but personally I
    like having only one. Makes backups much easier.

    Mike
     
    Mike Kujbida, Feb 13, 2006
    #8
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.