Update #1 on Samsung YH-J70J as Photobank

Discussion in 'Samsung' started by Henk & Marga Jamin, Dec 22, 2006.

  1. After many problems with Samsung (Canada) Customer Service and a lot of
    testing, the following must be noted about this unit:

    1. Samsung Customer Service sucks just like everywhere else. Bigtime!

    2. I have not been able to find any USB device that the YH-J70J can
    connect to reliably.

    3. It can connect sort-of some of the time to my D70s, but a data
    transfer usually locks up the unit, requiring a hard reset. When it
    does transfer files, it is exceedingly slow.

    4. A folder can hold a maximum of 1024 files and you can not create new
    folders on the unit. This little surprise is noted in their on-line
    manual.

    5. Folders with same names but different cases are OK on creation, but
    confuse the unit no end when it comes to deleting same.

    6. Samsung TWICE posted the wrong firmware on their support website!

    7. Original upgrade instructions were wrong and the current instructions
    are incomplete.

    Advice: unless you want an expensive paperweight, stay away from this
    unit!
    Unless you want a lot of aggravation, stay away from Samsung products!

    Below you will find my last communication from Samsung I received and my
    response.

    FROM SAMSUNG:
    Hello Mr. Jamin,



    Sorry for the inconvenience you are experiencing regarding firmware on
    the J70. I believe you have spoken with Yves regarding this issue. Yves
    is correct in stating that firmware will not resolve this issue. We do
    not have any firmware update on our website. The Firmware that is posted
    on Samsung’s website is the same version that is in your player. There
    are never any guarantees that all products will work or be compatible
    with USB Host feature. There is one firmware upgrade for this player but
    it is already installed on the units sold in Canada. No other firmware
    released afterwards.

    Unfortunately I could not find anything in Cassandra notes indicating
    that we are replacing your unit. Samsung cannot exchange or refund your
    purchase because there no fault found. If our device does not connect to
    some cameras, it does not mean unit is defective.



    Thank you for your time,


    Joseph Desimini

    Senior Level Technical Support
    Samsung Electronics Canada Inc
    55 Standish Court, Mississauga, Ontario, L5R 4B2
    http://www.samsung.ca

    TO SAMSUNG:

    Dear Sir,

    Your message is typical of responses (many rude) I have received from
    your so-called customer support.

    To re-iterate:
    I purchased this unit on September 21 at FutureShop Pointe Claire and
    that same evening found out that
    it did very slowly connect to my Nikon D70s, but during the subsequent
    transfer of images crashe
    requiring a hard reset.

    As I am used to shoddy software being sprung on unsuspecting consumers,
    I checked your support
    website and found a Version 2.0 posted for this unit. I downloaded this
    and found that with the posted
    instructions, it was impossible to have the unit accept this firmware.
    On the following monday I called 1-800-SAMSUNG and explained the
    problem. Your rep patched me
    through to "second tier support" where I explained my predicament. The
    gentleman assured me that he would
    check this out and call me back. He never did!
    I called again, and was told there was some kind of problem with the
    posted firmware and I should monitor
    the site for an update. An update was posted a week and a half later
    (Version 3.0).
    The zip file posted now contained two files. I again dowloaded this
    firmware and found that once again
    the unit would NOT accept it. The instructions on the website had now
    been replaced by (inclomplete)
    instructions with a screen-shot in Korean, which I unfortunately do not
    master.

    On the following monday I called 1-800-SAMSUNG again to report this
    problem. The attitude of your
    staff was to say the least adversarial, but after insisting I got yet
    again to talk to "second tier support".
    The gentleman ther said I must be doing something wrong, but he would
    get a unit and try for himself and
    call be back in about an hour. You guessed it: he never did call back.
    I called again later in the week
    and after the now usual fencing, I got to talk to him and he advised me
    that he had not been able to call
    back because his unit refused the upgrade as well, and he had tried with
    two more units with similar results.
    He said he would contact Korea and find out what was going on anf get
    back to me....

    I had also explained that there was some urgency as I was leaving on a
    four week vacation on Nov 18 and
    needed the unit working by then.. Again the discussion became
    adversarial where it was implied that your
    unit not working was really the fault of all USB equipment manufacturers
    but certainly not the fault of
    Samsung! I was told the problem would be rectified as soon as possible
    and I would be advised.
    Of course this did again not happen!

    I called again and asked to talk to someone in authority as this was
    getting ridiculous. I was now beyond the
    30 day return policy of FutureShop and was left with an expensive
    paperweight. I talked to Russell, who
    at least listened to this saga and opened the above ticket and promised
    to investigate.

    Imagine my surprise when a day later your website changed again and now
    Version 1.083 was posted. I
    downloaded this and this time it did install on the unit, but operation
    was as before. I did some firmware
    cracking while this went on, and you can see my findings on this
    ticket. For your perusal, I have attached
    the download instructions for this version and request that you pay
    particular attention to what version
    should be displayed after installation. In case you missed it, it shows
    3.00.

    I have tried the unit with a Nikon D70s with the above results. Any
    other USB device I have tried
    (Casio QV-R40 camera, Casio QV-R62, Vibe MP3 2GB and a number of flash
    drives) always results
    in a display of <FAILED TO CONNECT>.

    As neither on your site, nor on the box are any exclusions noted (and
    there must be many) I expect the unit
    to work as advertised or my money refunded.

    As I have stated on the ticket, if I do not receive an acceptable
    response from you by noon 22 Dec, this
    saga will become yet another post on USENET about the <uncommon>
    customer care, and I will continue
    to seek restitution or get the unit to work as advertised!

    Regards,

    Henk Jamin
     
    Henk & Marga Jamin, Dec 22, 2006
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.