very frustrating timecode problem with Final cut Express and Pro

Discussion in 'Amateur Video Production' started by double, Jan 30, 2006.

  1. double

    double Guest

    I have been having this problem with both FCE2 and FCP5

    Here is the situation. I shot an archive of a live theater performance
    with two cameras. The primary camera is a Canon GL-2, and the secondary
    camera is a small Canon ZR-85.

    when i try to capture the footage from either tape into FCE2 or FCP5 i
    get a error about timecode break. I've set it up to make a new clip
    when this happens but final cut is telling me, every 30 seconds or so,
    that there is a timecode error, and capturing an 80 min mini DV tape
    can take HOURS.

    I just don't think that this is possible - It looks like the time code
    is fine, so i don't know what the problem is. I have tried capturing
    from the GL-2, the ZR-85, and my girlfriend's Sony DCR-PC101 - all
    three camera's have the same issue. It doesn't seem to matter what tape
    i use either, there is a time code problem with it. And here is the
    thing, when i try to capture it again - (of course FCP tells me about a
    timecode break) but the break is never in the same place twice! How is
    this possible?

    Now, I am no pro, but if i shot a live performance and let both
    camera's roll without ever pausing or going back to review the tape,
    the timecode should be fine right? And there is no break in the numbers
    when viewed in final cut or the playback window of the camera. what
    gives? where is the break!?

    Here is what i am using:
    FCP 5
    FCE 2
    Power book g4
    1.5 GHz
    512 MB RAM
    Canon GL-2
    Canon ZR-85
    Sony DCR-PC101
    Panasonic Mini DV 80 minute tapes

    Where is the problem? Camera? Software? Source tape? Final Cut? enough
    RAM?

    I don't get it
     
    double, Jan 30, 2006
    #1
    1. Advertisements

  2. double

    Mike Kujbida Guest

    I know nothing about Final Cut but, whenever that's a problem in the PC
    world, the usual answer is that the user has neglected to set the date on
    the camcorder(s).

    Mike
     
    Mike Kujbida, Jan 30, 2006
    #2
    1. Advertisements

  3. double

    Bill Lee Guest


    So, do some testing:

    Test for system function:
    1) Shoot ten minutes of video on a new tape and try to capture this in
    FCE2/FCP5.
    2) Does it capture without timecode warnings?
    3) Does it capture in iMovie OK? Does iMovie split the capture up into
    clips (make sure you switch this functionality on in the Preferences),
    indicating that it too thinks there is a break in the timecode?
    4) Can you Print To Video using FCE/FCP?

    Test for cabling issues:
    1) Replace the FireWire cable with another one and retest for system
    function (above).
    2) Get a FireWire 800 -> Firewire 400 adapter cable and see if using the
    FireWire 800 port resolves the loss of timecode.
    3) If you have another Mac, try to capture from the cameras using the
    same same FireWire cable - try wiggling the cable during capture - does
    that cause a drop in timecode.

    Test for bus interference:
    1) Is there any other FireWire devices also on the same bus? If so,
    disconnect them and try again.

    Test for software issues:
    1) Reset the Power Manager
    2) Quit all applications that don't need to be running - 512MB is on the
    low side when running FCP5.
    3) Are you running Classic mode? If so, switch it off.
    4) Create a new user account, log in as that new user and attempt to
    capture the video again. Does the timecode issue persist?

    Make a FireWire-FireWire copy of one of the tapes to another camera. Try
    this new tape - does it have similar timecode issues. Since you are
    having timecode issues at different places each time, it is less likely
    to be a tape issue.

    Bill Lee
     
    Bill Lee, Jan 30, 2006
    #3
  4. double

    double Guest

    Thanks for the help ... i will give all of this a try. I've just
    ordered some more memory - maybe that will improve my luck.

    Do they make a fire wire 800 that connects to a 4 pin camera port?

    Would it be wise to chain the camera via my external hard drive? (I've
    heard different things regarding that)

    I haven't tried capturing to iMovie lately, but the last time i tried
    there was no issue. Let me try with these tapes.
     
    double, Jan 30, 2006
    #4
  5. Not sure if Mac's are clever enough for this ;-)

    Maybe SMART-monitoring of the harddrives are enabled?

    Maybe the hard-drive itself is fragmented, bad or maybe the OP is capturing
    to the Startup disk?

    cheers

    -martin-
     
    Martin Heffels, Jan 30, 2006
    #5
  6. double

    double Guest

    I'm not sure what you mean by "Smart monitoring?"

    I doubt the Hard Drives are the problem. they are new and work well for
    everything else, and i am not capturing to my PB hard drive

    Here's what i have done:
    I chained the camera via the external drive - no help

    I tried another fire wire cable - no help

    I tried to import to i-movie - the clips split up less than every
    minute. That made made me think that there is a problem with the
    timecode on the tape, so i rewound the tape and tried to recapture. The
    clips split up again but not in the same place - so now i don't think
    that had anything to do with timecode.

    I made a new account and tried to recapture in FCE 2- no help. (I
    fugured it would be the same in FCP)

    I'm still at a loss
     
    double, Jan 30, 2006
    #6
  7. SMART ("Self-Monitoring, Analysis, and Reporting Technology") is hardware
    monitoring system of your hard-drive. You have a bit of software running
    which requests the status of the hard-drive, and let's you know whether the
    drive is still ok, or showing failures (bad blocks). This polling can stall
    the data-transfer, and it is a good idea to switch it off. But again, I
    don't know whether Mac's support this.
    Ah ok, how new are they? New drives suffer from a hardware-test, where they
    write slow in the beginning to test their performance. Depending on the
    manufacturer, it takes roughly 10-20 power-up sequences to have them
    function normal. You can either reset this via software (probably not
    available for Mac), or switching your computer on and off a couple of
    times. In regular operation you don't really notice this, but with
    video-capturing, you notice slow down of the writing of the data.

    However in your other post you write you bought more memory. This might
    actually be the thing which will help you, as FCP is memory-hungry.

    cheers

    -martin-
     
    Martin Heffels, Jan 31, 2006
    #7
  8. double

    double Guest

    thanks ... i hope it is just the RAM issue
     
    double, Jan 31, 2006
    #8
  9. double

    Bill Lee Guest

    Capture to your local hard drive - even though there is theoretically
    enough bandwidth to capture from the camera(s) and write the data to an
    external FireWire drive, in practice this can have problems - including
    those you are experiencing. In general I always capture to my internal
    drive and if necessary copy media to an external drive after a capture.
    Have you tried setting the Scratch disk to the local PB drive, removing
    the external drive and tried a test capture?
    Good, that tends to eliminate a cable issue then.
    The key characteristic here is the non-consistent nature of the timecode
    breaks. This implies dynamic problems in the capture process that are
    unrelated to timecode breaks on the tape itself.
    OK, this implies it is not likely to be a corrupted preference file
    (although that probability was small given the problems were happening
    in three different applications).

    I don't know if your PB internal drive is configured as a single
    partition or not, but you have more than then try putting a new copy of
    the system software on another partition. Install FCP5 (without all the
    extras). Don't bother about software updates at this time - the goal is
    to quickly test to see if it's a system software issue. This should take
    you less than an hour to install. Boot from this other partition and do
    a test capture in FCP, on the internal HD.

    If you have only one partition, then build a system on your external
    FireWire drive and install FCP there too (again this should take no more
    than an hour in total and nowhere near that of your attention), again
    not worrying about the software updates. Boot from the external drive.
    Set the capture scratch disk to be the internal drive. Do a test capture
    in FCP5. Does it now capture without timecode breaks?

    I know it's frustrating, but there is a process to go through to narrow
    down the possible causes of your problems, generally going from the
    quick and easy test right up the the 'back up and install everything
    again from scratch'.

    Did you try and shoot a small amount of video and capture this?
    Did you try to Print to Video and check the tape for drop-outs in the
    video (a set of countdown clips written out to tape is good for picking
    out where you might be dropping frames on output.
    How much free space is on your disks? I try never to have less than 10%
    of a disk free to minimise disk latency issues from fragmentation.

    Other things to try:
    1) Open up the Activity Monitor and position the CPU load window where
    you can see it during a capture. Is there an application which appears
    to be sucking up a significant amount of CPU during the time you are
    running FCP or during the time the capture is occurring? How much free
    RAM do you have before, during and after the capture?
    2) Close all un-needed projects and sequences before starting a capture.
    Open projects and sequences take up RAM that may be needed for your
    capture. Do the capture as the first thing when you open your FCP
    project so the memory is unfragmented as possible.
    3) How was the video captured: SP or LP? You will get more errors and
    drop-outs on LP than SP, especially if the tape is played back on a
    camera/deck that did not write out the tape originally.
    4) What version of QuickTime is installed in your computer? What version
    of the system software is installed?
    4) [Not on the topic of trouble shooting] If you have access to FCP,
    then I would use that in preference to FCE. There are more tools in FCP
    than in FCE, especially for dealing with multiple tapes, timecode and
    keyframe attributes. The interface is almost the same for both, and I
    can't think of a good reason to run FCE if you have FCP available -
    unless you have to share your project with others who only have FCE
    available.

    Bill Lee
     
    Bill Lee, Jan 31, 2006
    #9
  10. Is it every 30 seconds or is it actually every minute?

    Presuming you're in NTSC land, my intial thought is that your recorder
    has drop-frame timecode and your FCP project is non-drop-frame - or
    possibly vice-versa!

    In drop-frame timecode, the timecode skips forward two frames every
    minute to keep the timecode running accurately to real time (a
    consequence of the 59.94Hz NTSC field rate compared to 60Hz). Possibly
    this skip is being interpreted as a timecode break because you haven't
    got the drop-frame mode set the same?

    Steve

    The Doctor Who Restoration Team Website
    http://www.restoration-team.co.uk
     
    Steve Roberts, Jan 31, 2006
    #10
  11. He said it happened every time at a different place.

    -m-
     
    Martin Heffels, Jan 31, 2006
    #11
  12. Ah, that'll teach me to skip-read! ;)

    Steve

    The Doctor Who Restoration Team Website
    http://www.restoration-team.co.uk
     
    Steve Roberts, Jan 31, 2006
    #12
  13. double

    double Guest

    Good advice ... let me try these out. Thanks for your help
     
    double, Jan 31, 2006
    #13
  14. double

    double Guest

    I didn't have that much time to fiddle with it this morning before
    work, but this is what i did.

    I cleaned up my computer and got rid of some applications that were
    unnecessarly running. I downloaded and ran a system optimizer program.
    I updated all of the software.

    I tried to capture to fcp while watching my cpu activity monitor. Now
    fcp and the other systems were using somewhere around 80% of the cpu
    when capturing, leaving 10 to 20 % free. Looks OK right? Then i watched
    the memory - and this is what i don't really understand. There was very
    little that was marked "free", but there was plenty that was marked
    "idle" Does anyone understand what the difference is?

    now it seems to be running a little better, but the clips are still
    splitting up (not as frequent as before) but nowhere close to what i
    want.

    I even tried to capture the video alone (to see if the problem was
    related to the audio) It still breaks up the clips.

    I know that there are other things to try that were suggested here, but
    i will need to attack them later when i have a little more time.

    My capture settings are :
    Device controll: FireWire NTSC
    Capture/Input: DV NTSC 48 kHz

    That seems right for a Canon mini Dv right?
     
    double, Jan 31, 2006
    #14
  15. double

    double Guest

    Sorry: When i said the memory was marked "idle" i meant it was marked
    "inactive"
     
    double, Jan 31, 2006
    #15
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.