WMP plays entire file perfectly but all editing softwares report terminal errors

Discussion in 'Amateur Video Production' started by easytoremember123, Jul 12, 2005.

  1. I have an MPEG movie which has a glitch some 2 minutes after it starts.
    But WMP 10 plays the movie entirely without a problem. I only realized
    and then located where the glitch is exactly using Virtualdub (it stops
    loading after the error). I went back to WMP and carefully watched that
    segment of the movie and I couldn't notice the glitch.

    I can't use any editing program to cut/split any part of the movie
    after the glitch (it's not just Virtualdub). All my editing softwares
    report that it has an error at that point and they can't continue. But
    if WMP could go right through it, surely there must be some application
    out there that can "fix" that glitch, allowing my editing softwares to
    function on the file? Any recommendations?
     
    easytoremember123, Jul 12, 2005
    #1
    1. Advertisements

  2. easytoremember123

    Bariloche Guest

    I would try loading the mpeg into VirtualDub with an Avisynth script

    DirectShowSource("TheMpegClip.mpg")

    or

    DirectShowSource("TheMpegClip.mpg", theFramerate)

    in case it doesn't guess the framerate.
     
    Bariloche, Jul 15, 2005
    #2
    1. Advertisements

  3. Thanks for the reply. I found out on my own that the best MPEG error
    fixer is VCDcutter. Don't try anything else.
     
    easytoremember123, Jul 16, 2005
    #3
  4. And for converting ASF files to AVI it's Stoik Video Converter.
     
    easytoremember123, Jul 16, 2005
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.