"X Drive Pro" USB connection Problem

Discussion in 'Australia Photography' started by Peter Collins, May 13, 2004.

  1. The "X Drive Pro" is a portable laptop harddrive that connects to
    computer via USB. It also includes card reader for most card types. [I
    intend to use it to back up my CF cards on a OS trip]

    My problem is , I was able to connect it to my computer once, and
    transfer files, but the next time I tried to connect via USB , the
    computer just refused to recognize the "X Drive Pro". My OS is Windows
    XP.

    THe X Drive Pro seems to read any inserted (CF) cards ok , and stores
    content on hard drive.

    I wondered if any one else had a similar problem and what the solution
    is?

    { I have sent a email to the manufacturer and also the company I
    purchased from in Melbourne, but no response so far.)

    thanks for any help.

    Peter Collins
    pcollins.-AT-.gil.com.au replace "-AT-" with "@"
     
    Peter Collins, May 13, 2004
    #1
    1. Advertisements

  2. Peter Collins

    Rusty Gunn Guest

    Hi Peter

    I had this once and then tried it in another usb port and it worked. Don't
    know what the problem was. Have you also installed the software that came
    with it , this may also help.

    --
    Regards

    Rusty Gunn

    (Please remove NOCRAPSPAM from Email before replying)
     
    Rusty Gunn, May 13, 2004
    #2
    1. Advertisements

  3. Peter Collins

    Rob Guest

    Are you connecting using only the supplied cable? Is it connected
    directly to the USB card at the rear of the computer or at the front of
    the computer? I ask as I have found my X-Drive at least to be
    problematic where used in conjunction with any USB extension cables.

    Rob
     
    Rob, May 13, 2004
    #3
  4. Peter Collins

    Merlin Guest

    The X Drive Pro does not require you to install software when using Windows
    XP.

    I use mine in Windows XP without installing any additonal software and it
    works fine.

    Maybe try uninstalling the software if you have installed it, try another
    USB port, or if possibly try it on someone elses Windows XP computer and see
    if the problem still exists.
     
    Merlin, May 13, 2004
    #4
  5. <SNIP>

    I have tried it on 2 other computers ( One XP and one Win2k SP4 ) ,
    and Can not get it to work. On all 3 computers , I tried in all USB
    ports.

    In all cases, it does not show up as a removable drive in explorer.

    Yes, I have installed the sw that came with it.

    Seems weird, worked once and then sstopped working.

    These computers talk to other USB devices OK , like a flash drive
    dongle, USB printer and USB scanner.

    I ran up the company I purchased from this afternoon, person that
    normally handles this stuff was away, so they will contact me
    tomorrow. ( As a aside, I am going on OS trip next Thursday, so if I
    can not get this sorted out soon I will have to get some thing else.)
     
    Peter Collins, May 13, 2004
    #5
  6. Yes, I am only using the supplied cable, ( it is about 1.2m long ). I
    am not using a extension cable. Thanks 4 the suggestion

    Peter Collins
     
    Peter Collins, May 13, 2004
    #6
  7. Try another cable.
     
    AU Digital POTD, May 13, 2004
    #7
  8. Peter Collins

    Ken Oaf Guest

    Sounds like your unit is faulty. If it reads cards, but you cannot transfer the
    data from it, then I would suggest there may be a broken connection in the USB
    socket.
     
    Ken Oaf, May 13, 2004
    #8
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.